Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-25-2010, 07:45 AM   #1
Forum Member




Join Date: Apr 2007
Location: Pennsylvania
Posts: 53
Help using A 50 1.4

I've got an older Pentax A 50mm 1.4 lens I would like to use with my K100. When mounted I cannot get the camera to work. The F value just continues blinking no matter what I do. Does the camera need to be on a certain setting? Program or maybe Av? I feel like I have tried everything but I assume I am missing something simple and easy.

Any help appreciated.

06-25-2010, 07:49 AM   #2
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,314
there are a couple of things to consider.

first of all, with an A series lens put it in A ( on the aperture ring) so you can use the camera to control aperture

Also, you should set the custom setting to use aperture ring, if you intend to control the aperture with the ring.

Note that the camera will meter and perform better with the lens in A trhan when using the aperture ring, and in the A position on thelens, you will aslo be able to use matrix metering and flash
06-25-2010, 08:20 AM   #3
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
As Lowell says, just set the aperture ring to "A" and you're good to go.

If in thte future you want to use an older lens that lacks the "A" position on the aperture ring, see the sticky thread at the top of the Beginner's forum on how to use manual lenses. But that's not necessary your lens - with the aperture ring on "A", everything works normally without the special procedures and compromises in functionality that result from setting aperture directly on the aperture ring.
06-29-2010, 04:15 AM   #4
Veteran Member
pcarfan's Avatar

Join Date: Sep 2007
Location: Dayton, Ohio
Photos: Gallery | Albums
Posts: 2,958
My A 50/1.7 is asking for the SR focal length, is this normal?

06-29-2010, 04:35 AM   #5
Site Supporter
Aristophanes's Avatar

Join Date: Jul 2008
Location: Dartmouth, Nova Scotia
Photos: Albums
Posts: 3,790
QuoteOriginally posted by pcarfan Quote
My A 50/1.7 is asking for the SR focal length, is this normal?
Yes. Indicate it's a 50 and you're good to go. This tells the camera's SR function how much to adjust.
06-29-2010, 04:54 AM   #6
Veteran Member
pcarfan's Avatar

Join Date: Sep 2007
Location: Dayton, Ohio
Photos: Gallery | Albums
Posts: 2,958
QuoteOriginally posted by Aristophanes Quote
Yes. Indicate it's a 50 and you're good to go. This tells the camera's SR function how much to adjust.
Thanks.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, help, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 05:56 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top