Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-17-2010, 01:48 PM   #1
Inactive Account




Join Date: Jan 2010
Location: Los Angeles
Posts: 32
help!!! major problem

hi im on a study abroad trip in greece for three weeks and yesterday my sigma 28mm 1.7/1.8 lens stopped working with my pentax k-x . i didnt drop the lens or anything and i really need to know what to do because thats my prime lens for this trip.

the problem: camera wont read the lens .. when i put the lens on the f-stop just flashes and it doesnt detect that a lens in on the camera. so if i do need to get it fixed are there any pentax users from greece or that have been to greece who know where i could get it fixed .. im in delphi for sunday july 17th and nafplion from the 18th - 28th

07-17-2010, 02:03 PM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,863
If the lens has an aperture ring make sure that it is set to the "A" setting.
07-17-2010, 02:03 PM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,264
Is the aperture ring on the "A" position? Otherwise, you might check that the contacts on the lens mount (camera and lens) are clean. Are other lenses affected?


Steve
07-17-2010, 02:19 PM   #4
Inactive Account




Join Date: Jan 2010
Location: Los Angeles
Posts: 32
Original Poster
it the aperture ring was in A ... thanks i feel like a dummy lol ... still new to photography

07-17-2010, 04:19 PM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,264
QuoteOriginally posted by LosHollyBeach Quote
it the aperture ring was in A ... thanks i feel like a dummy lol ... still new to photography
I was not very clear in my earlier post. The aperture ring needs to be in the "A" position for easiest usage on your camera. When the ring is off the "A" position, the camera does not know the f/stop and will display F---. Your camera may be used with the aperture ring off the "A" position, but it requires changes to the camera setup and will only really work in M (manual) mode with your Sigma lens. (Translation...it is not worth the trouble...leave the ring on "A".)


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, greece, im, k-mount, lens, pentax, pentax lens, slr lens, trip
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major problem with Lightroom 2 dugrant153 Digital Processing, Software, and Printing 18 05-25-2010 05:44 AM
Major question!! MergePhotography Photographic Technique 23 01-08-2009 12:32 AM
another major upgrade axl General Talk 17 11-30-2008 03:13 AM
Speculation on what might be next for each major manufacturer. gkopeliadis Pentax News and Rumors 76 07-05-2008 04:17 AM
Major Gaffe with new to me Sigma 28 f1.8 kev.pride Post Your Photos! 2 05-09-2008 03:15 AM



All times are GMT -7. The time now is 11:57 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top