Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-04-2010, 10:08 AM   #1
Veteran Member
future_retro's Avatar

Join Date: Jun 2010
Location: Western Washington
Posts: 572
DA 15mm autofocus problem

Really sorry for starting two threads in such quick succession but this one was unexpected and a bit urgent

I just got my DA 15 in the mail, when the focus ring is turned all the way to infinity (where it wont turn anymore) it switches the actual focus setting on my K7 to manual focus. I have to spin the ring back to the right to get the camera to back into AF mode.

Actually when the focus ring is at infinity it turns into a fully manual lens, the "select focal length" menu comes up when I turn on the camera and all automatic functions go away. A slight turn of the focus ring turns it back into an auto lens, but if it is hunting and spins the ring all the way to the infinity point it goes back into fully manual everything.

is my lens defective? this seems really really odd.


Last edited by future_retro; 08-04-2010 at 10:30 AM.
08-04-2010, 11:23 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,614
Sounds like it might be defective, so I wouldn't risk it and just return/exchange it. My first 15mm had a defect as well.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-04-2010, 11:30 AM   #3
Veteran Member
kalison's Avatar

Join Date: May 2010
Location: Utah
Posts: 376
I'd be sending that back. Doesn't do this with your other limited glass?
08-04-2010, 11:35 AM   #4
Veteran Member
future_retro's Avatar

Join Date: Jun 2010
Location: Western Washington
Posts: 572
Original Poster
QuoteOriginally posted by Adam Quote
Sounds like it might be defective, so I wouldn't risk it and just return/exchange it. My first 15mm had a defect as well.
Well that makes me feel a little better. I have heard very few quality control issues with the Limited lines and thought that just maybe this was just some outlandish feature, if it's defective at least I'll be able to get working one.

QuoteOriginally posted by kalison Quote
I'd be sending that back. Doesn't do this with your other limited glass?
I'll check tomorrow when it comes, I doubt it will act the same, but if it does it might be a bug in that new K7 firmware causing this. However my two other quick shift lenses don't have this problem

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, da, focus, infinity, k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SFXn autofocus problem Radix Pentax Film SLR Discussion 3 02-22-2010 06:10 AM
K-m autofocus problem. What could this be? amaurosis Pentax DSLR Discussion 2 10-23-2009 10:46 AM
K100D Super AutoFocus Problem oguzgel Pentax DSLR Discussion 4 01-07-2009 10:20 AM
Autofocus problem with K10D Old Timer 56 Pentax DSLR Discussion 18 07-05-2008 01:21 PM
FA 50mm F1.4 AutoFocus problem vizjerei Pentax SLR Lens Discussion 2 11-09-2007 09:29 AM



All times are GMT -7. The time now is 03:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top