Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-23-2007, 11:03 AM   #1
Inactive Account
roy's Avatar

Join Date: Sep 2006
Location: D/FW area, Tx.
Photos: Gallery
Posts: 1,712
1.4x-s problem

when i use this on the tamron 300/2.8 in Av i can only set the ap down to f4.
if i put my tamron 2x on i can set it down to f2.8. anybody know why this is.

08-23-2007, 03:03 PM   #2
Senior Member
Groundloop's Avatar

Join Date: Aug 2007
Location: Toronto, Canada
Photos: Gallery
Posts: 236
Hi there. First time poster.

I'm guessing that the Tamron converter isn't transmitting the lens data to the camera correctly, whereas the Pentax converter is. Even though the Tamron -> Tamron combo allows you to set an aperture of f2.8, the aperture you actually have is f5.6, since both focal length and aperture are multiplied by whatever the teleconverter "factor" is. The f2.8 lens plus the 1.4 teleconverter results in an aperture of f4.0, which is what your camera meter is telling you.
08-23-2007, 03:16 PM   #3
roy
Inactive Account
roy's Avatar

Join Date: Sep 2006
Location: D/FW area, Tx.
Photos: Gallery
Posts: 1,712
Original Poster
neither of these have that capability.
the 1.4x-s works on every other A lens i have. 105 f2.5 macro also, except it says f2.4..
08-23-2007, 03:17 PM   #4
roy
Inactive Account
roy's Avatar

Join Date: Sep 2006
Location: D/FW area, Tx.
Photos: Gallery
Posts: 1,712
Original Poster
oh? sorry , welcome to the board. lotta nice people here.

08-23-2007, 06:06 PM   #5
Pentaxian
Arpe's Avatar

Join Date: Sep 2006
Location: New Zealand
Photos: Gallery | Albums
Posts: 4,344
I just picked up a 2x-s. Goes fine on my Pentax glass, but when I stick a Sigma on it, my 17-70/2.8-3.5 can suddenly go down to f1.2!! Cool, I thought these TCs were supposed to let in LESS light, not more (Hey - I'm joking alright?)

But despite the above problem the camera seems to expose okay. I haven't tested it properly yet though.
08-23-2007, 06:24 PM   #6
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
It alsmost sounds like the 1.4x TC is capable of modifying the F Stop value to compensate for the change, while the other is not.

I know my sigma 1.4x does not compensate for the change in apature or focal length on the 70-200 F2.8 sigma lenses.

I would be interested if you are seeing F4.0 when the 1.4x is attached, do you get a focal length of 450mm?? i.e. correct for magnification>
08-23-2007, 07:02 PM   #7
roy
Inactive Account
roy's Avatar

Join Date: Sep 2006
Location: D/FW area, Tx.
Photos: Gallery
Posts: 1,712
Original Poster
NO
neither the TCs or the cam is able to report this. i've cked the exif.. these just do not have the ability to it.. IIRC there are NO TEs and no model of pentax lenses or camera that change the EXIF when using TCs. none
08-27-2007, 01:27 PM   #8
Veteran Member
Ben_Edict's Avatar

Join Date: Jul 2007
Location: SouthWest "Regio"
Photos: Albums
Posts: 3,303
QuoteOriginally posted by Lowell Goudge Quote
It alsmost sounds like the 1.4x TC is capable of modifying the F Stop value to compensate for the change, while the other is not.

I know my sigma 1.4x does not compensate for the change in apature or focal length on the 70-200 F2.8 sigma lenses.

I would be interested if you are seeing F4.0 when the 1.4x is attached, do you get a focal length of 450mm?? i.e. correct for magnification>
You can bet, that the old Pentax A 1.4-s does not report anything to the camera, it just puts the lens's signals through (lens signals in A-lenses just means shorted contacts). It sure will not take its own multiplying factor into account. I just imagine, that some lenses are chip-wise not fully compliant with the Pentax data transmission protocol and report nonsense (or the camera interprets nonsense). I regularily get strange EXIF data entries, when using older Sigma lenses - and they don't improve when adding a TC...

Ben

08-27-2007, 01:30 PM   #9
Veteran Member
Ben_Edict's Avatar

Join Date: Jul 2007
Location: SouthWest "Regio"
Photos: Albums
Posts: 3,303
QuoteOriginally posted by roy Quote
when i use this on the tamron 300/2.8 in Av i can only set the ap down to f4.
if i put my tamron 2x on i can set it down to f2.8. anybody know why this is.
Have you checked, whether it actually opens the aperture fully, when you set the smallest f-number? It could be, that just the f-stop read-out is nonsense, but that otherwise everything works o.k. If the aperture really doesn't open fully (beyond f4), I would contact Tamron and discuss that with a technician.

Ben
08-27-2007, 02:08 PM   #10
roy
Inactive Account
roy's Avatar

Join Date: Sep 2006
Location: D/FW area, Tx.
Photos: Gallery
Posts: 1,712
Original Poster
i can't set the lens to 2.8 in AV mode. it does close down to f4 when i hit the shutter. in M mode it'll work just fine a f2.8. looks like when using this if i need f2.8 i'll do it in M. no biggy.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, pentax lens, slr lens, tamron
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
MZ-7 (ZX-7) Problem Hello_Photo Pentax Film SLR Discussion 13 03-23-2015 07:32 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
What was the problem here? straightshooter Pentax Film SLR Discussion 15 09-15-2008 02:46 PM
this may be a problem nathancombs Pentax DSLR Discussion 24 02-02-2008 10:39 PM



All times are GMT -7. The time now is 09:44 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top