Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2010, 03:19 AM   #1
Inactive Account




Join Date: Jun 2010
Photos: Gallery
Posts: 13
srewdrive da*300 on faulty K7

My K7 has a problem with its sdm motor, so the k7 gets on tilt when a sdm lens is attached to it. Even on manual focus the k7 beeps continuesly because of the af focuspoint isn't locked.

Which contact on the lens/k7 have to be blocked so that the da*300 will work with the srewdrive and a normal af focus? I already tried the smd contacts on the lens but that didn't work

k7 goes for warranty repair in november, first a visit to Paris

a help is appriciated

10-02-2010, 03:54 AM   #2
Veteran Member
danielchtong's Avatar

Join Date: Jul 2007
Location: Toronto
Posts: 756
QuoteOriginally posted by kokkieblanda Quote
My K7 has a problem with its sdm motor, so the k7 gets on tilt when a sdm lens is attached to it. Even on manual focus the k7 beeps continuesly because of the af focuspoint isn't locked.

Which contact on the lens/k7 have to be blocked so that the da*300 will work with the srewdrive and a normal af focus? I already tried the smd contacts on the lens but that didn't work

k7 goes for warranty repair in november, first a visit to Paris

a help is appriciated
Is that the fault of K7 or the lens? Can you isolate the issue in confirming that the lens SDM works in any camera body?

Call me old fashion. I hate the idea of stuffing lens with electronics which is the main culprits of repair woes. Ideally there should be nothing electronics like FA or A lens. I have DA*200mm and I feel intimidated in updating my other lenses to SDM only version.
Hope your repair works out well.
Both my FA135mm and F50mmF1.7 work perfect since (18 yrs vintage). The FA135mm is still the fastest amongst all Pentax lenses (incl SDM ones)

Daniel
10-02-2010, 04:03 AM   #3
Inactive Account




Join Date: Jun 2010
Photos: Gallery
Posts: 13
Original Poster
there's nothing wrong with the lens. That's been on various other k7/x's to test it. Its my k7 that has the problem and i havn't had time to bring it in for repairs. Have to use it to often
10-03-2010, 08:36 AM   #4
Inactive Account




Join Date: Jun 2010
Photos: Gallery
Posts: 13
Original Poster
blink!

anyone know a solution?
how let to think the K7 that de da*300 isn't a sdm lens so that the screw will work (and the af)?

10-03-2010, 12:01 PM   #5
Pentaxian




Join Date: May 2007
Location: WW community of Pentax users
Photos: Gallery | Albums
Posts: 2,128
QuoteOriginally posted by kokkieblanda Quote
...how let to think the K7 that de da*300 isn't a sdm lens so that the screw will work (and the af)?
If that were possible, a lot of Pentax users would be extremely happy.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, da*300, focus, k-mount, k7, lens, pentax lens, sdm, slr lens, srewdrive
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Faulty equipment or faulty photographer? (K-x) mamba909 Pentax DSLR Discussion 22 02-15-2010 12:16 PM
Faulty FA 80-320 EsBee Pentax SLR Lens Discussion 10 08-28-2009 06:49 PM
Faulty DA* 16-50mm ?? aleonx3 Pentax SLR Lens Discussion 12 05-11-2009 03:21 PM
Is my k200d faulty or maybe not??? :( flamenco Pentax DSLR Discussion 9 01-16-2009 10:29 PM
Faulty K10D AE-L? Simon Pentax DSLR Discussion 2 03-03-2007 04:11 PM



All times are GMT -7. The time now is 08:24 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top