Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-07-2010, 12:15 PM   #1
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
New K 1.8/55. Do I have a problem?

Hey guys, I just got myself a SMC Pentax 1.8/55 from a certain auction site.
It looks plenty nice and sharp from the first few shots I took with it but there is one problem, when I turn the focusing ring I can feel and hear a sound of what I can only describe as grease and dust smearing.
Everything else seems fine, the iris seems to work flawlessly at every stop and it meters just about as any other manual lens I tried, but this thing with the focusing ring bothers me a little, it also seems like it causes the focusing ring not to turn as smoothly as it should, though it does pretty well for me and I don't really know how it is suposed to be since I never used a K series lens before.
Well, I would like to know what is this thing I am describing and if it can have any effect on the lens' usability (currently or in the future), so I would like to hear from anyone who had a similar experience or maybe knows a way to fix this, if it does require fixing.

Thanks,
Pablo

11-07-2010, 12:41 PM   #2
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
Rotate the focusing ring back and forth as fast as you can for like a full minute.

If it isn't affecting the images, you can learn to live with it, as annoying as it might be.

But what I suggest is the same fix used for audio electronics knobs that get dirty. You're simply grinding down and loosening those particles.
11-07-2010, 12:47 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,361
After you start using the lens, the ring should loosen up to normal levels. The same thing happened to be when I bought my first 35-105mm- the lens could barely zoom at first, and there was a similar noise. After I had been using it for about a month, everything seemed normal, and the zoom ring was smooth and noise-free.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-07-2010, 01:04 PM   #4
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
QuoteOriginally posted by Ira Quote
Rotate the focusing ring back and forth as fast as you can for like a full minute.

If it isn't affecting the images, you can learn to live with it, as annoying as it might be.

But what I suggest is the same fix used for audio electronics knobs that get dirty. You're simply grinding down and loosening those particles.
Thanks for the advice. I tried it and it did help a little with the sand-like feeling but the main thing that bothers me is the grease or whatever lubricant is there.
I'm not really thinking about a real disassemble of the lens since I will probably ruin things more than I can fix and sending it to a pro is not realistic considering the modest price I payed for the lens.
I guess I want a miracle solution if there is any, or maybe I'll just use it as it is and forget about the so called defect just like I handled the dust in my viewfinder.

11-07-2010, 01:05 PM   #5
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
QuoteOriginally posted by Adam Quote
After you start using the lens, the ring should loosen up to normal levels. The same thing happened to be when I bought my first 35-105mm- the lens could barely zoom at first, and there was a similar noise. After I had been using it for about a month, everything seemed normal, and the zoom ring was smooth and noise-free.
thanks Adam, that is a relief, I hope I will have a similar experience
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Problem with K7 sammie Pentax DSLR Discussion 4 05-09-2010 09:28 PM
NEW and PROBLEM samgrom Welcomes and Introductions 6 03-06-2010 05:20 AM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
Do you have a problem... Alvin Pentax DSLR Discussion 15 03-03-2007 01:17 AM



All times are GMT -7. The time now is 10:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top