Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-22-2010, 08:08 PM   #1
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,235
DA*16-50mm "squeaks" ... faulty?

Hello to all!

So, I have this DA*16-50 for a while ... probably near three years, and it recently started to squeak a bit during AF.
It still focuses right on the button but it does, very so often, SEEM to hunt ever so slightly, along with the squeak.

I did search the forum but found only one reference and it wasn't all that helpful.

Is this a sign of an upcoming SDM failure?
I am wondering if I am becoming one of those unfortunate owners of a faulty or soon-to-die DA*16-50.

Any feedback would be appreciated before I pack it up and send it away for repair.


JP

11-23-2010, 08:21 AM   #2
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,816
I haven't heard of and squeaking associated with SDM failure. Mine just abruptly failed after about 2 years. Working one minute then not the next. It also made the LCD on my camera turn off after about 1 second. That was odd too. It's at the Pentax repair place now and they've said that this was related to the contacts and not SDM failure ($217 for repair). Squeaking? Sounds like it has a trip to the repair house soon. The other thought I have is that you've gotten 3 years out of it and that seems to be at least twice the usual amount I've read about for most SDM troubles.

Whatever happens on this, I think it would be a good idea to report back how this progresses and is (hopefully) resolved.

Hey it works for now.
11-23-2010, 09:12 AM   #3
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,235
Original Poster
QuoteOriginally posted by blackcloudbrew Quote
I haven't heard of and squeaking associated with SDM failure. Mine just abruptly failed after about 2 years. Working one minute then not the next. It also made the LCD on my camera turn off after about 1 second. That was odd too. It's at the Pentax repair place now and they've said that this was related to the contacts and not SDM failure ($217 for repair). Squeaking? Sounds like it has a trip to the repair house soon. The other thought I have is that you've gotten 3 years out of it and that seems to be at least twice the usual amount I've read about for most SDM troubles.

Whatever happens on this, I think it would be a good idea to report back how this progresses and is (hopefully) resolved.

Hey it works for now.
This is odd because if I recall properly, my first DA*16-50 did a bit of squeaking days before it just quit.
I just got to the store to get copies of my invoice, and it has actually been 2 years, and not 3 years as I mentioned earlier.

I contacted the people at Pentax Canada this morning, directly instead of going through the paces with the seller.
I will ship it tomorrow.
Hopefully this will not take a whole month like it did last time.

I will keep you posted here of course.

Thanks for the reply.

JP
11-23-2010, 09:15 AM   #4
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
My 16-50mm squeaks for some time now.
It has just been returned from a front element / zoom drive repair mand cleanup by Pentax Germany.
It still squeaks....

- Bert

11-23-2010, 03:56 PM   #5
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,235
Original Poster
QuoteOriginally posted by bymy141 Quote
My 16-50mm squeaks for some time now.
It has just been returned from a front element / zoom drive repair mand cleanup by Pentax Germany.
It still squeaks....

- Bert
Still squeaks, really?
Does it focus properly and without hunting?

JP
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
da*16-50, k-mount, pentax lens, slr lens, squeak
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Da16-50mm vs Tamron 17-50mm .. or is my kx faulty? kxr4trids Pentax SLR Lens Discussion 4 11-13-2010 05:14 PM
Faulty equipment or faulty photographer? (K-x) mamba909 Pentax DSLR Discussion 22 02-15-2010 12:16 PM
Faulty DA* 16-50mm ?? aleonx3 Pentax SLR Lens Discussion 12 05-11-2009 03:21 PM
Faulty SD card. Bramela Pentax Camera and Field Accessories 10 01-20-2009 12:39 PM
Faulty K10D AE-L? Simon Pentax DSLR Discussion 2 03-03-2007 04:11 PM



All times are GMT -7. The time now is 11:07 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top