Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-10-2007, 04:41 PM   #1
Inactive Account




Join Date: Sep 2007
Posts: 2
Sigma 28mm problem?

Hello! I just picked up a Pentax K100d and ordered a Sigma 28mm f/1.8 for it. It came in the mail today, and when I attached it, the top LCD just flashes AV, and when you look through the viewfinder it just flashes F. Can anyone tell me what the problem is? Thanks!

10-10-2007, 04:46 PM   #2
Inactive Account




Join Date: Sep 2007
Posts: 2
Original Poster
Nevermind, I figured it out!!!
10-10-2007, 05:33 PM   #3
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
Welcome to Pentax Forums arrrggghhh,

I hope that you post a couple of pic's with it.
I'm interested getting one of those lenses myself.
10-10-2007, 05:38 PM   #4
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Yeah that damn "A" setting on the aperture ring.....

11-13-2007, 10:40 AM   #5
Veteran Member
gokenin's Avatar

Join Date: Oct 2007
Location: lowell,ma
Posts: 1,890
just ordered this lens

hi I just bought this lens for my k100d and its my first non pentax lens and was wondering what you have to do to get it to work with the pentax you said something about the A button? pardon me for asking something that may be easy to understand when I get it but wanted to get some help so I can know what to expect when I get it
11-13-2007, 10:48 AM   #6
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,611
QuoteOriginally posted by gokenin Quote
hi I just bought this lens for my k100d and its my first non pentax lens and was wondering what you have to do to get it to work with the pentax you said something about the A button? pardon me for asking something that may be easy to understand when I get it but wanted to get some help so I can know what to expect when I get it
If it is an auto-aperture lens, make sure it is set on the "A" setting. If it is a fully manual lens (no "A" setting on the aperture ring") you have to go to the custom menu and change the "allow aperture ring" (I think that is the correct syntax) to option 2 "permitted".

NaCl(why that isn't the default setting I'll never know)H2O
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
28mm, flashes, k-mount, pentax lens, sigma, sigma 28mm, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 28mm f/1.8 and Sigma 30mm f/1.4: 3 Questions Biro Pentax SLR Lens Discussion 0 03-06-2010 03:12 PM
SMC A 28mm 2.8 problem(?) question bsimon Pentax SLR Lens Discussion 4 01-12-2009 07:21 PM
Sigma 28mm F1.8 Gooshin Pentax SLR Lens Discussion 5 08-26-2008 10:51 AM
sigma 28mm ex f1.8? Geekybiker Pentax SLR Lens Discussion 5 04-09-2008 06:17 PM



All times are GMT -7. The time now is 02:31 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top