Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-15-2011, 02:44 AM   #31
JHD
Veteran Member




Join Date: Jan 2010
Photos: Albums
Posts: 1,407
QuoteOriginally posted by sean Quote
Got it back. Pentax Canada charged me $225, saying the front ring was cracked. I'm a bit skeptical, but I'm happy to have this lens back in time for summer.
Now might be a good time to dump it. I just picked up a Sigma 50-150mm f2.8 II EX DC HSM APO for $790 complete with a 10 year warranty! Obviously Sigma - unlike Pentax - can provide a 10 year warranty because they've put enough quality, substance and thought in their product to back it up as such.

05-15-2011, 06:09 AM   #32
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by JHD Quote
Now might be a good time to dump it. I just picked up a Sigma 50-150mm f2.8 II EX DC HSM APO for $790 complete with a 10 year warranty! Obviously Sigma - unlike Pentax - can provide a 10 year warranty because they've put enough quality, substance and thought in their product to back it up as such.
Out of curiosity, are the 10 year warranties in Canada transferable? I only ask because I know in the US they are not.
05-15-2011, 04:39 PM   #33
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
Fellow Canadian here....with the same issue. SDM replaced on 50-135 9 months ago, now it's starting to squeak again....which is the first thing that happened first time around...argh! Pentax Canada is saying that it will only warranty their replaced motors for 6 months...I'm SOL
My 16-50 was sent to Japan for it's motor replacement, but Pentax Canada did the replacement on the 50-135.....maybe I'll find a way to send it back to Japan and get it done right!
05-15-2011, 04:45 PM   #34
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
QuoteOriginally posted by JHD Quote
Now might be a good time to dump it. I just picked up a Sigma 50-150mm f2.8 II EX DC HSM APO for $790 complete with a 10 year warranty! Obviously Sigma - unlike Pentax - can provide a 10 year warranty because they've put enough quality, substance and thought in their product to back it up as such.
Hello fellow Okanagan'er! I'm in Summerland. Having serious issues with SDM and am looking at the 50-150 2.8 from Sigma. How are you liking it? Is it as sharp as the Pentax DA*50-135?

05-15-2011, 06:25 PM   #35
JHD
Veteran Member




Join Date: Jan 2010
Photos: Albums
Posts: 1,407
QuoteOriginally posted by dgaies Quote
Out of curiosity, are the 10 year warranties in Canada transferable? I only ask because I know in the US they are not.
AFAIK warranties (regardless of the manufacturer) are not usually transferable, so probably not.
05-15-2011, 06:31 PM   #36
JHD
Veteran Member




Join Date: Jan 2010
Photos: Albums
Posts: 1,407
QuoteOriginally posted by mokey Quote
Hello fellow Okanagan'er! I'm in Summerland. Having serious issues with SDM and am looking at the 50-150 2.8 from Sigma. How are you liking it? Is it as sharp as the Pentax DA*50-135?
Hey, that's cool. I can see Summerland from my back window. The Sigma hasn't arrived yet but I should have it by Tuesday at the latest. Maybe we can get together sometime and you can try it for yourself?
05-15-2011, 06:55 PM   #37
Moderator
Site Supporter
Blue's Avatar

Join Date: Jun 2008
Location: Florida Hill Country
Photos: Gallery | Albums
Posts: 17,166
QuoteOriginally posted by mokey Quote
Fellow Canadian here....with the same issue. SDM replaced on 50-135 9 months ago, now it's starting to squeak again....which is the first thing that happened first time around...argh! Pentax Canada is saying that it will only warranty their replaced motors for 6 months...I'm SOL
My 16-50 was sent to Japan for it's motor replacement, but Pentax Canada did the replacement on the 50-135.....maybe I'll find a way to send it back to Japan and get it done right!
Check your warranty laws. Here in Florida, if it is still under warranty, that "replacement" motor argument would not fly. I would love to drag someone's arse down here from Colorado with there 2-bit lawyer in tow.
05-15-2011, 07:16 PM   #38
Loyal Site Supporter
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,646
I read this thread about yet another SDM failure, feeling sympathy for the OP. "Poor Sod" I thought. I've never had a problem with my 50-135. I love that lens. Reading yet again about SDM failures when the lens has not been used, I took mine out of it's case where it has been for the fortnight since I last used it, mounted it on the K-5 and .....it's dead.

Hmm, tried the K-7, the K-x and even a 1.4x TC (desperate measure, I realise) ...nothing.

Looks like I'm another victim of the SDM failure. Bugger. This means sending the lens to Japan, as there is no way of fixing it in Oz, as far as I'm aware.


Last edited by Bramela; 05-16-2011 at 12:32 PM.
05-15-2011, 08:47 PM   #39
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
QuoteOriginally posted by Blue Quote
Check your warranty laws. Here in Florida, if it is still under warranty, that "replacement" motor argument would not fly. I would love to drag someone's arse down here from Colorado with there 2-bit lawyer in tow.
It was out of warranty the first time it was replaced, but it sure would have been nice to make the second warranty longer than 6 months...
05-16-2011, 04:45 AM   #40
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
You might want to check out https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/130429-diy-sup...or-repair.html
I haven't tried it yet, but only because I have a K10D running V1.2 where the lens still works in screw drive.
05-16-2011, 12:24 PM   #41
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
QuoteOriginally posted by calicojack Quote
You might want to check out https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/130429-diy-sup...or-repair.html
I haven't tried it yet, but only because I have a K10D running V1.2 where the lens still works in screw drive.
If you'd know how many things I've taken apart, that didn't quite go back together....you wouldn't suggest that!
05-16-2011, 12:35 PM   #42
Site Supporter
Bramela's Avatar

Join Date: Jan 2007
Location: Newcastle Australia
Photos: Gallery | Albums
Posts: 5,281
QuoteQuote:
I read this thread about yet another SDM failure, feeling sympathy for the OP. "Poor Sod" I thought. I've never had a problem with my 50-135. I love that lens. Reading yet again about SDM failures when the lens has not been used, I took mine out of it's case where it has been for the fortnight since I last used it, mounted it on the K-5 and .....it's dead.

Hmm, tried the K-7, the K-x and even a 1.4x TC (desperate measure, I realise) ...nothing.

Looks like I'm another victim of the SDM failure. Bugger. This means sending the lens to Japan, as there is no way of fixing it in Oz, as far as I'm aware.
I have three DA* lenses, so far, so good. But it is always in the back of my mind, WHEN....

Does not C.R.Kennedy's not fix these lens? Being the Australian official agent for Pentax.
05-16-2011, 12:47 PM   #43
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
QuoteOriginally posted by JHD Quote
Hey, that's cool. I can see Summerland from my back window. The Sigma hasn't arrived yet but I should have it by Tuesday at the latest. Maybe we can get together sometime and you can try it for yourself?
Sounds great...It's hard to find any sigma lenses around here that are made for Pentax.
05-16-2011, 01:58 PM   #44
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
QuoteOriginally posted by mokey Quote
If you'd know how many things I've taken apart, that didn't quite go back together....you wouldn't suggest that!
I know that predicament very well. Perhaps that's another reason why I haven't tried it yet.
05-16-2011, 03:09 PM   #45
Loyal Site Supporter
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,646
QuoteOriginally posted by Bramela Quote
I have three DA* lenses, so far, so good. But it is always in the back of my mind, WHEN....

Does not C.R.Kennedy's not fix these lens? Being the Australian official agent for Pentax.
Bruce, my understanding is that CRK send then lenses back to Japan for repair, but I could be wrong. I'm waiting for 9am to give them a call.

My other alternative is to take the lens and a link to the repair page to a camera tech. My lens is out of warranty anyway, so no harm in letting someone other than Pentax/CRK pull it apart. As it happens Nagami Camera Service is located a couple of blocks from me. He has a good reputation with the local camera crowd, so I might give the lens to him to try and repair. If his quote for the work is too high I'll have a go at trying the repair myself.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, da* 50-135mm, failure, k-mount, lens, lenses, pentax, pentax lens, sdm, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failure to Launch hriddle Troubleshooting and Beginner Help 7 01-09-2011 03:52 PM
Possible K10D AF failure - suggestions? PentaxScott Pentax DSLR Discussion 1 06-02-2009 10:02 PM
D-BG2 grip failure CharlieO Pentax Camera and Field Accessories 3 01-29-2008 04:57 AM
K10D failure?! time-snaps Pentax DSLR Discussion 8 07-28-2007 06:11 AM



All times are GMT -7. The time now is 08:27 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top