Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-16-2011, 06:06 PM   #46
JHD
Veteran Member




Join Date: Jan 2010
Photos: Albums
Posts: 1,407
QuoteOriginally posted by mokey Quote
Sounds great...It's hard to find any sigma lenses around here that are made for Pentax.
You're right, however I did pick up a Sigma 10-20 and 17-70 with Sigma CPLs at London Drugs here in town.

05-19-2011, 08:37 PM   #47
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,134
Mine gave up, but I got it working again, sort of.

QuoteOriginally posted by sean Quote
This is becoming an annual tradition! Sent this lens in to Pentax Canada about this time last year, and they:
- Replaced Motor
- Replaced PCB
- Replaced Gear Plate Assy.

The SDM has failed again; the lens cannot autofocus at all, on K20, K5. Tried leaving it attached to a powered on camera for a while, no luck.

I think I'm going to ask Pentax for a whole new copy of this lens; are newer units any less likely have SDM autofocus failure?

My other SDM lenses are OK so far. Wish Pentax would allow the lenses to be used as screwdrive in case of SDM failures.
Mine came back late last year, complete with new module, as yours is, and would not fire up yesterday. What I found when comparing it to my 16-50 was that the focus ring was not as free moving. I spent about 10 minutes tonight turning the ring back and forth and trying to AF, and repeating, and it's back working again. I think what I need to do is to free up the focus ring from time to time. A royal pain, of course, and not really satisfactory for a lens with a price tag like this one.

I'm not sending it back to Pentax because it is now out of warranty, and I won't spend that kind of cash on something that will break again, not to mention the lens being away from me for a month or two. I also found that leaving the lens in AF.S on my K10 gives me catch-in-focus when the AF doesn't work, which kind of offsets the problems a bit (but not enough!).

In any case, I have an AF (sometimes) lens with superb optics, and that does not change with MF. It also works beautifully with my AFA 1.7X converter, giving me an 85-230/4.8 lens that focuses just fine, using the screw drive. There are snaps from a test run on the Flickr site with the AFA 1.7X.

I am also, of course, sending a note to Pentax about this dissatisfaction. At least I can vent, even if nothing results.
05-19-2011, 08:47 PM   #48
Veteran Member




Join Date: Mar 2009
Location: Midwest
Photos: Gallery
Posts: 1,407
QuoteOriginally posted by wizofoz Quote
I read this thread about yet another SDM failure, feeling sympathy for the OP. "Poor Sod" I thought. I've never had a problem with my 50-135. I love that lens. Reading yet again about SDM failures when the lens has not been used, I took mine out of it's case where it has been for the fortnight since I last used it, mounted it on the K-5 and .....it's dead.

Hmm, tried the K-7, the K-x and even a 1.4x TC (desperate measure, I realise) ...nothing.

Looks like I'm another victim of the SDM failure. Bugger. This means sending the lens to Japan, as there is no way of fixing it in Oz, as far as I'm aware.
Before you give up... Mine did that after an extended stint in the cabinet. I polished the contacts with an eraser (one of the white ones for ink) and it started working just fine.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, da* 50-135mm, failure, k-mount, lens, lenses, pentax, pentax lens, sdm, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failure to Launch hriddle Troubleshooting and Beginner Help 7 01-09-2011 03:52 PM
Possible K10D AF failure - suggestions? PentaxScott Pentax DSLR Discussion 1 06-02-2009 10:02 PM
D-BG2 grip failure CharlieO Pentax Camera and Field Accessories 3 01-29-2008 04:57 AM
K10D failure?! time-snaps Pentax DSLR Discussion 8 07-28-2007 06:11 AM



All times are GMT -7. The time now is 03:15 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top