Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-21-2011, 12:21 PM   #1
New Member




Join Date: Mar 2011
Location: Chatham
Posts: 3
18-135 mm auto focus

I recently purchased a 18-135 mm lens for my Pentax K10D. I can't get the auto focus to work. I have checked my settings. AFS is selected. However, when you view the settings through the viewer, it is showing MF. I have other lenses which work fine on this setting. How do I go about trouble shooting this problem?

03-21-2011, 12:25 PM   #2
Veteran Member




Join Date: Aug 2009
Posts: 2,311
QuoteOriginally posted by Jed Mooar Quote
I recently purchased a 18-135 mm lens for my Pentax K10D. I can't get the auto focus to work. I have checked my settings. AFS is selected. However, when you view the settings through the viewer, it is showing MF. I have other lenses which work fine on this setting. How do I go about trouble shooting this problem?
Have you updated your camera with the latest firmware?

Isnt that needed for the K-10, to be able to handle SDM and DC lenses?
03-21-2011, 12:25 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,993
Update your K10D to firmware version 1.3

Download

  1. Unzip the file
  2. Copy the .bin to the root of a formatted SD card
  3. Insert the card into your camera and ensure it is fully charged
  4. Turn the camera power on while pressing the Menu button
  5. Select "Yes" when prompted on the screen
  6. Once the screen displays "Complete", you can turn off your camera

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-21-2011, 06:48 PM   #4
New Member




Join Date: Mar 2011
Location: Chatham
Posts: 3
Original Poster
Thanks Adam. That was the answer I was looking for. I updated from 1.0 to 1.3. Everything is working great.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, focus, k-mount, mm, pentax lens, settings, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
10 Reasons why manual focus primes are better than those new auto focus zoom lenses JoepLX3 Pentax SLR Lens Discussion 188 07-25-2012 03:28 PM
Auto focus: which is better K7 or K-X? gfmucci Pentax DSLR Discussion 18 07-17-2010 10:15 AM
Auto-focus doesn't auto anymore jonhock Pentax SLR Lens Discussion 4 11-26-2009 11:28 AM
IS there Auto Focus assist in Auto with the Metz 58? madman6767 Pentax DSLR Discussion 5 01-26-2009 06:27 AM
DA* 50-135 will not auto focus w/new K200D Billy Batson Pentax SLR Lens Discussion 14 01-15-2009 10:57 PM



All times are GMT -7. The time now is 06:06 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top