Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-22-2011, 09:07 PM   #1
Inactive Account




Join Date: Mar 2008
Location: Nashville Tennessee
Posts: 7
problems with sigma 70-200mm 2.8

Hi
I have a K20 that i use all the time with the DA* lenses so HSM works with .
so the Sigma 70-200mm f/2.8 II EX DG APO Macro HSM has been in my camera case for quite a while,
maybe 6-10 months as I keep the 16-50 and 50-135 in the quick bag most of the time.
Anyway when I took it out and mounted it, the focus was slow at first and searched all the way out to infinity and stopped slowing down as it went .Didnt start back anymore.

Replaced both battries cleaned the contacts ,installed and remounted lense multiple times and worked the manual focus switch back and forth ,on and off the camera,
at the moment I have my K10 loaned out so I dont have another body I can try it on

So question is am I forgetting anything or any other suggestions before I become concerned enough to send it in to be looked at?
thanks
Chris

04-22-2011, 09:16 PM - 1 Like   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
It would be a good idea to test the lens on another body before getting it serviced under warranty, although this does sound like SDM failure to me. Also, make sure your K10'd firmware is updated to the latest version when you get it back, as otherwise SDM will trivially not work with it

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-23-2011, 03:56 AM   #3
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,678
So much for HSM being more reliable than SDM if that's the case.

I assume you've been using your DA* lenses OK to date.
Sorry if it is a failure. You should definitely have it fixed if indeed it doesn't work on any other Pentax dSLR that is SDM/HSM compatoble (all of them except the *ist D series, the K110D and K100D).
04-23-2011, 04:16 AM   #4
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,556
Not so nice to read since I'm up for my first Sigma HSM lens to buy.

04-23-2011, 07:07 AM   #5
Inactive Account




Join Date: Mar 2008
Location: Nashville Tennessee
Posts: 7
Original Poster
Thanks for the replys The K10 will be back soon and I will update it and try and report what happens *fingers crossed*
and yes both of the DA* have worked perfectly.As did the Sigma the last time i used it .
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
70-200mm, camera, focus, hsm, k-mount, pentax lens, sigma, sigma 70-200mm, slr lens, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Sigma 17-70 at K-7 rcaboni Pentax SLR Lens Discussion 2 12-29-2010 08:29 AM
sigma 24-70 focus problems? Graisin Pentax SLR Lens Discussion 3 12-07-2010 03:28 AM
sigma 8-16 problems? hoanpham Pentax SLR Lens Discussion 6 11-20-2010 08:14 AM



All times are GMT -7. The time now is 10:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top