Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-23-2011, 06:22 PM   #16
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
That didn't work either Would pentax customer support be able to help?

06-23-2011, 06:40 PM   #17
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
I know this is a pain in the ass but start from step one and walk us through everything you are doing. From the time you turn the camera on and tell it what focal length lens you are using. Go from there to the point where you are unable to take a photo. Something isn't right either with the communication or with the camera (I suspect the former).

06-24-2011, 07:13 AM   #18
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
I turn on the camera, set dial to "M", push the green button (have also tried the av+- button) and then push the shutter release, the screen goes black when I push the shutter release but dosn't take a picture.
06-24-2011, 07:26 AM   #19
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
This only happens with That lens?

The screen goes black and then comes back? or does it stay that way (as it may if taking a very long exposure)?

Do you have another lens with an aperture ring (A type) that you can try this with by taking the lens off of A? For that matter, What happens with Any lens in M mode when you press the green button (or Av +-)?



06-24-2011, 07:39 AM   #20
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
The only other lens I have is the 18mm-55mm that came with it and it works perfect, in manual and auto modes the screen only stays black for as long as I hold down the shutter release and then comes back, which I have tried holding it down longer in case it was a very long exposure.

With my other lens the green button, which is currently set to optical preview, works just fine giving me an optical preview. The AV+- lets me select either the f-stop or shutter speed which I can then adjust with the E-dial.
06-24-2011, 07:46 AM   #21
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,252
Try doing it without live view, and use the dof preview button instead of the green button. It should work in live view, but IMO it's a lot less confusing through the VF
06-24-2011, 07:48 AM   #22
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
Live view dosn't work with the M lens.
06-24-2011, 08:08 AM   #23
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by Jesse Quote
Live view dosn't work with the M lens.
That doesn't make any sense at all. I can turn on my camera with NO lens and live view works. The only way I can get things to NOT work, is to set custom menu item 27 (on the k5) to Prohibited (on the KR it is item 22).



06-24-2011, 08:15 AM   #24
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
What shutter speed is the camera reporting after hitting the button to meter? Is it possible the "screen" (hopefully you mean viewfinder) is black simply because it's a long shutter speed because you are using too small an aperture at too low an ISO?
06-24-2011, 10:23 AM   #25
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
This is what I see when I have the m lens on.
06-24-2011, 11:48 AM   #26
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 823
QuoteOriginally posted by Jesse Quote
This is what I see when I have the m lens on.
This is what you get after pressing the green button? That doesn't look right. Shutter speed should be displayed after hitting the green button. I'm not sure if it matters but it looks like you're on continuous shooting mode. Can you try single frame shooting?
06-24-2011, 11:57 AM   #27
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
QuoteOriginally posted by K57XR Quote
This is what you get after pressing the green button? That doesn't look right. Shutter speed should be displayed after hitting the green button. I'm not sure if it matters but it looks like you're on continuous shooting mode. Can you try single frame shooting?
I am in the pic, but I've been trying it in single frame everytime...Thats what it looks like before and after pushing the green button or the AV+- button. They seem to not be doing anything.
06-24-2011, 12:06 PM   #28
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 823
Someone may have asked it already but just in case, do you have the green button "Action in M Mode" set to "Tv shift"?
06-24-2011, 12:17 PM   #29
Inactive Account




Join Date: Jun 2011
Location: Illinois
Posts: 18
Original Poster
I didn't but I just tried it and got the same result.
06-24-2011, 12:44 PM   #30
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 823
On the K-x there are two things I need to set for stop down metering on M lenses: Aperture Ring="Permitted" and Green Button Action in M Mode="Tv Shift". These are a must. I'm assuming K-r has the same or at least similar menu options. If you have those two set up accordingly, you should be good to go.

I know you have a K-r but I believe it is similar to the K-x as far as menu options go.
Maybe this link will help:Using Older Lenses with the PENTAX K-x | Pentax Support
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, lens, pentax lens, series, series lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do custom "artistic" or even "funny" lens caps evenexist? lovemehate Pentax SLR Lens Discussion 35 02-10-2016 09:10 AM
Which Zoom Lens? "Tamron AF 18-250mm", "Pentax-DA 18-250mm" or "Sigma 18-250mm" hoomanshb Pentax SLR Lens Discussion 4 07-30-2010 09:50 AM
K-mount Experts: How to convert a "KAF2" lens to "KF"? panoguy Pentax SLR Lens Discussion 24 07-08-2010 05:20 PM
For Sale - Sold: Vivitar Series 1 70-210mm 2.8-4.0 Macro lens (ver 3 by Komine) with the "A" jjdgti Sold Items 8 11-04-2009 02:55 PM
What do the different lens series "names" mean? Neisey Pentax SLR Lens Discussion 8 08-19-2009 10:13 AM



All times are GMT -7. The time now is 08:31 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top