Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-03-2011, 10:51 PM   #1
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
SR and Livewview Problem w/ Sigma 24-70 DG HSM on K5 :(

Hi All,

Wonder if there is any guys here using the same lens: the latest version Sigma 24-70/2.8 DG HSM...

I have this for a while, quite like its optical performance and quiet AF. But it has some problem w/ my K-5. The lens is very sharp at all focal length when I switch off SR. But when SR is on, the photos are all blurry, definitely not fixable by adjusting AF. It's like the camera can't decide which focal length to use for SR, end up over compensates the 'hand shaking'. And liveview AF doesn't work at all, it just refuses to lock focus when I set the camera to liveview Have to use MF in liveview.

Wonder if is anyone here using the same lens, might check out if yours have the same problems?

Thanks and cheers!

Frank

08-03-2011, 11:34 PM   #2
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Are you switching off HSM when you switch on SR? You can't use both.

I've heard of problems with Sigma lenses and liveview, you need to contact Sigma about this as from memory they need to "rechip" the lens.
08-04-2011, 12:31 AM   #3
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
QuoteOriginally posted by twitch Quote
Are you switching off HSM when you switch on SR? You can't use both.

I've heard of problems with Sigma lenses and liveview, you need to contact Sigma about this as from memory they need to "rechip" the lens.
How can you switch off HSM? There is only an AF/MF switch on the lens ...
08-04-2011, 12:50 AM   #4
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
Okay, seems I'm not the only one who has problem w/ HSM lens in LV mode:

no focus with K7-Lifeview and Sigma HSM lenses??: Pentax SLR Talk Forum: Digital Photography Review

Called our Sigma service center just now, they can rechip the lens for me. Will pay them a visit when free

Love the lens btw...

08-04-2011, 02:04 AM   #5
Veteran Member
theperception2008's Avatar

Join Date: Aug 2009
Location: Łódź, Poland and Riverside, California, U.S.A
Photos: Gallery | Albums
Posts: 488
Are you leaving the lens' OS system on along with the in-body camera SR on? You should only choose one stabilization system. Otherwise, the two systems will try to compensate for each other.
08-04-2011, 10:03 AM   #6
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
QuoteOriginally posted by theperception2008 Quote
Are you leaving the lens' OS system on along with the in-body camera SR on? You should only choose one stabilization system. Otherwise, the two systems will try to compensate for each other.
This lens doesnt have OS built in, just HSM...
08-04-2011, 10:21 AM   #7
Veteran Member
theperception2008's Avatar

Join Date: Aug 2009
Location: Łódź, Poland and Riverside, California, U.S.A
Photos: Gallery | Albums
Posts: 488
ahh okay, I am mistaken I thought I saw OS in the op. time to go get some sleep :-P Sorry Frank!
08-04-2011, 11:00 AM   #8
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
When you look into photome exif info (only original jpg from the camera) you can see at what focal length the SR was set to. Then you know if it is just off by focallength or something else is going on.

08-04-2011, 04:58 PM   #9
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
QuoteOriginally posted by frank Quote
This lens doesnt have OS built in, just HSM...
oops, sorry Frank, I misread that bit too
08-04-2011, 06:10 PM   #10
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
QuoteOriginally posted by theperception2008 Quote
ahh okay, I am mistaken I thought I saw OS in the op. time to go get some sleep :-P Sorry Frank!
QuoteOriginally posted by twitch Quote
oops, sorry Frank, I misread that bit too
No prob. guys. You are trying to help me anyway

QuoteOriginally posted by RonHendriks1966 Quote
When you look into photome exif info (only original jpg from the camera) you can see at what focal length the SR was set to. Then you know if it is just off by focallength or something else is going on.
The focal length recorded in EXIF is accurate, but SR just goes wild, same with liveview Confirm it's the lens compatibility issue, need to be rechipped by Sigma as someone else did at DPR.

Will let you guys know how it goes.

Cheers!

Frank
08-06-2011, 07:14 PM   #11
Veteran Member




Join Date: Jun 2007
Location: Buffalo/Rochester, NY
Photos: Albums
Posts: 1,133
This might explain some inexplicably soft images I've been getting with this lens. It doesn't happen all the time, but often enough to really annoy me.

Is there more info on this? I'd like to contact Sigma about this but I'm sure I'll get the runaround unless this is a well documented issue.
08-08-2011, 09:01 AM   #12
Veteran Member




Join Date: Jun 2007
Location: Buffalo/Rochester, NY
Photos: Albums
Posts: 1,133
I went ahead and contacted Sigma about this issue and they stated the issue is NOT about rechipping but the lenses needing to be calibrated to the body. They want me to send the lenses and camera in. I also use these lenses with the K20 and sometimes the K10 - how can I ensure their calibration won't mess up the lenses' performance on those cameras?

Oy... my head hurts.
08-08-2011, 04:13 PM   #13
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
QuoteOriginally posted by George Lama Quote
I went ahead and contacted Sigma about this issue and they stated the issue is NOT about rechipping but the lenses needing to be calibrated to the body. They want me to send the lenses and camera in. I also use these lenses with the K20 and sometimes the K10 - how can I ensure their calibration won't mess up the lenses' performance on those cameras?

Oy... my head hurts.
Hmm, I haven't got chance to visit our Sigma service center yet! Although it's just 5min drive from my place.

I'll try to go there on wed or thur. Will update here.

Meantime you can switch off SR and give them a try.

Cheers!
08-09-2011, 10:09 PM   #14
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Original Poster
Here is an update as promised:

I skipped lunch today, went to our Sigma Service Certer. Showed the service guy the problem w/ the lens on my K5. He brought the camera and lens into their service room, came out in less than 5min. Now the lens can lock focus in liveview, and SR works too! He told me he just updated the frmware (for the lens), that's all. FOC even my lens isn't covered by local warranty

Now I'm even happier w/ the lens.
08-10-2011, 01:24 AM   #15
Veteran Member




Join Date: Jan 2009
Location: Budapest
Posts: 821
QuoteOriginally posted by George Lama Quote
how can I ensure their calibration won't mess up the lenses' performance on those cameras?
They don't change anything in your camera. It is just needed as a reference, to calibrate the lens to that particular body (due to manufacturing tolerances in cameras). So the calibration doesn't/won't affect your other lenses.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, dg hsm, k-mount, lens, liveview, pentax lens, slr lens, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20d HSM lens problem sa_lontoc Troubleshooting and Beginner Help 10 08-14-2011 07:23 PM
Wanted - Acquired: Sigma 150-500mm HSM, 150mm MACRO HSM, Sigma 18-250 HSM, Sigma 10-20mm HSM mackloon Sold Items 7 05-01-2011 02:25 AM
Follow-up to my thread below: sigma 17-50 HSM vs 18-50 macro vs 18-50 macro HSM? Loren E Pentax SLR Lens Discussion 22 02-05-2011 07:43 PM
problem with k-x & Sigma 70-200 2.8 II HSM video? servaas-products Pentax DSLR Discussion 6 11-10-2010 02:34 PM
Anyone used Sigma 70-200 non-HSM AND HSM? which is faster AF? Arpe Pentax SLR Lens Discussion 10 03-24-2010 04:28 PM



All times are GMT -7. The time now is 03:45 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top