Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2011, 03:14 PM   #1
Veteran Member
channeler's Avatar

Join Date: Jun 2007
Location: Northwich Cheshire England
Photos: Gallery
Posts: 1,008
Vivitar Series 1 1.4x Teleconverter

I had been using the Kenko1.5x SHQ version and a similar 2x MC7 version with my Pentax DA*300mm and was getting satisfying results. I was able to get autofocus with the SHQ 1.5x. Unfortunately I lost all my TCs when we were on holiday in France last year and got caught in a flash flood and had to escape leaving all our belongings behind. I thought I could replace the TCs but ended up with the latest versions, Kenko P-AF 1.5x Teleplus MC DG and P-AF 2x Teleplus MC7 DG. Not only does the 1.5x not provide autofocus with my DA300 but I can't even access the camera menu which is a real pain. I have to do the settings before putting the lens/TC on. The same applies to the 2x. I have always had to use manual focus with the older version of the 2x but I could access the menu and was even able to adjust the focal length on the shake reduction menu (though was never really sure if that actually did much). As far as I can remember it also enabled me to use the in-focus light in the viewfinder.

The Vivitar 1.4x and 2x and the Bower 2x now seem to be the only teleconverters which can be purchased as new for the pentax system, apart from Sigma TCs. My question is, though I know there has been a little discussion about these TCs, has anyone got any sample images taken with them combined with a DA*300 or if anyone can comment on the IQ compared to Kenko and Tamron TCs? Also, if these TCs work on a DA*300 (apart from SDM I understand) do they avoid the problems of the latest DG Kenko which I outlined above eg: access to camera menu, use of in-focus light in viewfinder?

Paul

12-15-2011, 07:25 PM   #2
Loyal Site Supporter
baro-nite's Avatar

Join Date: Aug 2011
Location: North Carolina, USA
Photos: Gallery | Albums
Posts: 4,298
Bumping this up as I am having the same issues, having just picked up a Pro Optic 1.4 TC, labelled "DG P/AF". From pictures and other reports I believe this to be the usual 4-element TC design based on the old Kenko/Tamron PZ version and sold under various brands, including Vivitar. It has the PZ contacts on the camera mount side, but lacks any corresponding contacts on the lens mount side. (It has the little flange where the PZ contacts would go, just no contacts.)

Seems to work fine with my screw-drive AF lenses. No surprise that AF doesn't work with an SDM lens (DA* 200). I wasn't expecting it to, so no problem. But I discovered the same issue you're having: menu, info, and Fn buttons don't work. Also, focal length is not transmitted to the camera and it uses the last manually entered value for shake reduction. I must set the AF switch to manual to be able to shoot.

I tried covering the PZ contacts (and flange) on the TC with electrical tape, but no change to the above symptoms. Again, these issues appear only with the SDM lens mounted. Everything seems to work fine with the kit lens.

BTW this is a K10D with the latest firmware (I think).

Any suggestions (Paul or anyone)? Am I risking my camera and/or lens to use this combination?
12-19-2011, 05:30 PM   #3
Loyal Site Supporter
baro-nite's Avatar

Join Date: Aug 2011
Location: North Carolina, USA
Photos: Gallery | Albums
Posts: 4,298
After reading this thread I tried shorting the data pin on the lens side of the TC. This resulted in the following changes to the behavior described above with the DA* 200:

menu, info, and Fn buttons now work
indicated aperture is two stops slower than actual setting (range shown is 5.6 to 32, resulting in actual aperture settings of 2.8 to 22).
metering off, but consistently so -- despite indicating smaller than actual aperture, selected shutter speed in Av mode is faster, resulting in about one stop underexposure

Interesting. Anyone have suggestions on different approaches to this? This is just guesswork for me.
12-21-2011, 01:57 AM   #4
Pentaxian
philbaum's Avatar

Join Date: Oct 2007
Location: Port Townsend, Washington State, USA
Posts: 3,659
With the K10D, i think you should hold the menu button down and turn the camera on to find out if you have the latest firmware, then confirm with the Pentax site.

The early K10d needed a firmware change to access the sdm lenses, if memory serves. Don't remember the ver. now but you should be able to get that off the pentax site.

12-21-2011, 05:48 AM   #5
Loyal Site Supporter
baro-nite's Avatar

Join Date: Aug 2011
Location: North Carolina, USA
Photos: Gallery | Albums
Posts: 4,298
Thanks PaulPhil. I am using the latest firmware (1.3.1). The lens works fine without the TC.

Last edited by baro-nite; 01-19-2012 at 07:18 AM. Reason: correction
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
2x, access, dg, in-focus, k-mount, kenko, light, menu, pentax lens, slr lens, tcs, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Vivitar 100mm f/2.8 Macro 1:1 Manual Focus PKA OR Vivitar Series 1 Macro yyyzzz Sold Items 6 10-22-2009 05:18 AM
For Sale - Sold: Vivitar 90mm f2.8 macro (1:1); vivitar series 1 70-210mm (ver. 3); and Tam 2x jkglogau Sold Items 10 10-06-2009 06:32 PM
For Sale - Sold: Vivitar 100mm f/2.8 Macro 1:1 Manual Focus PKA Same optics as Vivitar Series jjdgti Sold Items 10 10-05-2009 05:19 AM



All times are GMT -7. The time now is 07:41 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top