Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2011, 05:07 PM   #1
Site Supporter




Join Date: Apr 2011
Location: Oklahoma
Posts: 309
"A" apeture setting doesn't work

I picked up a Pentax-A 24mm lens off eBay, and the "A" setting doesn't seem to work on my K-X. Is there something I can try to make it work?

09-22-2011, 05:28 PM   #2
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
In the [C]ustom Menu, did you set Using Aperture Ring to Permitted?
09-22-2011, 05:34 PM   #3
Site Supporter




Join Date: Apr 2011
Location: Oklahoma
Posts: 309
Original Poster
Yeah that was set. I put the lens back on and it is working now. Does it have to be on "A" when you turn on the camera?
09-22-2011, 05:40 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,984
No, that shouldn't matter. Perhaps the ring on your lens is worn or poorly aligned.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-22-2011, 06:26 PM   #5
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,314
I would agree with adam, in the A position you should not need to "use aperture ring"

by setting USE aperture ring to permitted, it may let the shutter trip but it won't get the camera body controlling the lens.

check and see if you have F--- where the aperture shouldbe on the top display.

If so, the camera will behave like a K mount.

remove the lens, and check that the pin for the automatic mode is sticking out when in the A position, also check that the pin is shorted to the lens mount
09-22-2011, 07:14 PM   #6
Site Supporter




Join Date: Apr 2011
Location: Oklahoma
Posts: 309
Original Poster
I haven't gotten it to repeat the issue. How do I check the pin for automatic mode? I wonder if the pin was slightly out of place the first time I mounted it.
09-22-2011, 07:25 PM   #7
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,314
With the lens off the camera see if there is a pin about 3/10 of an inch from the lens locking slot. The pin should stick out about 1/16 th of an inch ( maybe a little less) with the lens in the A position and retract when you move it out of A
09-22-2011, 08:31 PM   #8
Site Supporter




Join Date: Apr 2011
Location: Oklahoma
Posts: 309
Original Poster
The pin does move slightly closer when I move it from f/22 to A. At this point, I am not sure what I did to get it to not work the first time.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
sigma 17-170 hsm macro on k-r - "a" setting? gop1ayoutside Visitors' Center 1 09-13-2011 11:10 PM
Copying pentax's "vibrant" color setting in Lightroom? scathontiphat Digital Processing, Software, and Printing 7 02-17-2011 05:34 PM
Setting "exposure" for live view? Gimbal Pentax K-5 3 01-21-2011 12:34 AM
3rd Party Lenses with "A" setting BrentPDX Pentax SLR Lens Discussion 7 01-06-2011 05:36 AM
Suggestion Can we add a setting to control the size of "Latest threads in which you've post"? Laurentiu Cristofor Site Suggestions and Help 2 11-21-2010 12:43 AM



All times are GMT -7. The time now is 04:56 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top