Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-12-2007, 08:29 PM   #1
New Member




Join Date: Nov 2007
Location: Long Island, NY
Photos: Gallery | Albums
Posts: 8
K10D not regonizing AF lens as AF

I have a Sigma UC Zoom 28-70mm AF lens that my K10D thinks is a manual focus lens. When I switch from MF to AF I can feel the camera engage the lens as a AF (the focusing ring gets more resistant when I turn it) but the view finder indicates that it a MF lens. Other Sigma lens work fine on the 10D and this lens works fine on my ZX-5. Any ideas what may be causing this. I used an alcohol pad to clean the contacts but it did not help. THe K10D also won't show the f stop it just indicates F--.

Thanks,
John

12-12-2007, 08:58 PM   #2
Veteran Member
Jodokast96's Avatar

Join Date: Oct 2007
Location: Erial, NJ USA
Photos: Gallery | Albums
Posts: 2,133
Sounds like the contacts aren't quite, well, contacting. I sometimes run into this when using all of my extension tubes with a heavier lens. There is the tiniest bit of play that seems to be just enough to keep one of the contacts from touching. Once I play with it a bit it's fine.
12-13-2007, 01:18 AM   #3
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
Does the lens have an aperture ring?
Is it set to "A"?
12-13-2007, 05:32 AM   #4
New Member




Join Date: Nov 2007
Location: Long Island, NY
Photos: Gallery | Albums
Posts: 8
Original Poster
Yes it does but that should not affect either the autofocus or the display of the f stop.

12-13-2007, 06:28 AM   #5
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
If the lens is not set to A, you will see "F--" in the display.
12-13-2007, 10:45 AM   #6
New Member




Join Date: Nov 2007
Location: Long Island, NY
Photos: Gallery | Albums
Posts: 8
Original Poster
Sorry, I didn't realize that. F-- is displayed when the lens is set to A. It seems strange that this is the only lens that is not communicating with the K10D but will work fine with the ZX-5.
12-13-2007, 11:30 AM   #7
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,451
QuoteOriginally posted by Time Freeze Quote
Sorry, I didn't realize that. F-- is displayed when the lens is set to A. It seems strange that this is the only lens that is not communicating with the K10D but will work fine with the ZX-5.
TF - you have faulty contact between the lens and the body. This is confirmed by the F-- viewfinder display.

Make sure the mount is not loose on the lens/body.

Make sure all the little contact "ball bearings" move freely in the lens - it is not impossible for a bit of grit to be holding one of the contacts up too high to make good contact with the body lens mount.

Hope you find the problem soon.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, af lens, k-mount, k10d, lens, mf, pentax lens, sigma, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: K10D body, DA 18-55mm kit lens, Tamron DiII AF18-250mm lens; Tamrac Velocity 8 gimmepizza Sold Items 9 12-01-2009 05:26 AM
Wide-angle lens to replace K10D kit lens StacyA1973 Pentax SLR Lens Discussion 20 03-07-2008 02:43 PM
Lens for K10D EAD Studios Pentax SLR Lens Discussion 16 01-08-2008 08:36 PM
Newb AF lens question about lens for K10D pentaxbling Pentax SLR Lens Discussion 3 08-15-2007 05:52 AM



All times are GMT -7. The time now is 04:46 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top