Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-23-2006, 10:45 AM   #1
Inactive Account




Join Date: Dec 2006
Location: uk
Posts: 8
pentax ist ds and tamron 90mm SP 2.8 macro lens

Hi, i have just purchased a older Tamron SP 90mm 2.8 Macro lens with a pka mount assuming it would work in TV and AV modes..this is not happening..i have allowed use of aperture ring in custom settings but to no avail....anyone any ideas has to why this lens doesn't adjust the aperture....thanks...pentaxsteve

12-23-2006, 10:54 AM   #2
Veteran Member
HogRider's Avatar

Join Date: Sep 2006
Location: Arizona, USA
Photos: Gallery
Posts: 608
I am assuming you have an adaptall II adapter (with the contacts) and your camera is set correctly....

Check that adaptall adapter real carefully. I had the same exact problem once with the identical setup.
I sold the lens so I can't look at it now, but from what I remember there was no "A" setting it was something like AE or similar on the aperture ring. Make sure it is set to that.

Also make sure all the contacts are clean. An eraser tip works great to clean them. After you mount the lens on the camera look at the LCD screen:
If besides the AV there is a "--" it means you have no contract. Try to wiggle the lens on the camera and give it a little more twist after it is already in position.

That's the way I got mine to work.
12-23-2006, 11:25 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,946
Sorry for interrupting, but I'm wondering how you managed to post in the site news section, lol. I'll have to check the forum permissions and move this thread

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-23-2006, 12:01 PM   #4
Inactive Account




Join Date: Dec 2006
Location: uk
Posts: 8
Original Poster
apologises

Apologises to admin for putting the question in the wrong section..i got a little lost being a first time poster..it won't happen again...cheers pentaxsteve

12-23-2006, 12:04 PM   #5
Inactive Account




Join Date: Dec 2006
Location: uk
Posts: 8
Original Poster
re tamron macro lens

Hi Redhawk..thanks for that...i am still trying but to no avail...the lens has a adaptall II mount and a AE position but the camera does not reconise the lens...thanks for posting a reply...pentaxsteve
12-23-2006, 12:10 PM   #6
clm
Senior Member




Join Date: Sep 2006
Posts: 220
With A lenses in Av mode, you set the aperture with the dial on the camera body. In Tv, lens has to be set to A. Allow aperture ring only applies to K and M series lenses.
12-23-2006, 12:48 PM   #7
Inactive Account




Join Date: Dec 2006
Location: uk
Posts: 8
Original Poster
Thanks clm....would you know if there is a difference between AE and A on the aperture ring......as i said camera doesn't reconise the lens at all.it seems like the aperture is wide open all the time...cheers
12-23-2006, 05:55 PM   #8
Veteran Member
HogRider's Avatar

Join Date: Sep 2006
Location: Arizona, USA
Photos: Gallery
Posts: 608
QuoteOriginally posted by pentaxsteve Quote
Hi Redhawk..thanks for that...i am still trying but to no avail...the lens has a adaptall II mount and a AE position but the camera does not reconise the lens...thanks for posting a reply...pentaxsteve
Your welcome. I wish I could have helped more. I somehow think it is a contact problem, which seems to be common with older adapters and converters.

Can you at least use the lens in manual mode? Camera in M, set aperture on lens to desired number and then hit AE-L button. Camera should step down lens for a sec, meter and set correct exposure time. I do a lot an manual macro pictures with older non A lenses in that mode and never found it bothersome.

12-23-2006, 08:30 PM   #9
clm
Senior Member




Join Date: Sep 2006
Posts: 220
Sorry, I don't know. I would assume A and AE means the same thing, but I don't know anything about the Adaptall lens mount. Does the aperture stop down when you remove it from the camera? The blades could be stuck, but that wouldn't explain why the camera doesn't recognize the lens.
12-24-2006, 01:54 AM   #10
Forum Member




Join Date: Sep 2006
Location: Vancouver, BC
Posts: 81
pentaxsteve, just wanted to check a couple of things with you...

Does your adaptall 2 adapter have 3 circular contacts on the back of the adapter (the part that touches the camera body) and does it have "PK/A" printed on it?

On my PK/A adapter there is a position on the aperture ring marked "AE". You need to press a black tab on the adapter to move the ring into the AE position (and to move it out of the AE position). Otherwise you are at f/22. On my DS the top display will not show an aperture value if the lens is not in the AE position.

If you have the older Adaptall 2 without the 3 contacts then you need to do what RedHawk suggested about using the camera in M mode. You still won't get an aperture value in the LCD though just a change in shutter speed.
12-28-2006, 10:47 AM   #11
Inactive Account




Join Date: Dec 2006
Location: uk
Posts: 8
Original Poster
thanks clm...thanks Kami...yes to pka and 3 contacts,yes it goes into AE by pressing the black tab..but no i still get don't get an aperture value nor any aperture noise but thanks for the info...Thanks Redhawk...looks like i'll be working in manual mode...no problem really but i thought either the mount or the lens was faulty....

anyway cheers everyone have a good new year...

Last edited by pentaxsteve; 12-28-2006 at 10:48 AM. Reason: wrong word entered in text
01-01-2007, 05:14 AM   #12
Site Supporter




Join Date: Nov 2006
Posts: 187
QuoteOriginally posted by RedHawk Quote
I am assuming you have an adaptall II adapter (with the contacts) and your camera is set correctly....

Check that adaptall adapter real carefully. I had the same exact problem once with the identical setup.
I sold the lens so I can't look at it now, but from what I remember there was no "A" setting it was something like AE or similar on the aperture ring. Make sure it is set to that.

Also make sure all the contacts are clean. An eraser tip works great to clean them. After you mount the lens on the camera look at the LCD screen:
If besides the AV there is a "--" it means you have no contract. Try to wiggle the lens on the camera and give it a little more twist after it is already in position.

That's the way I got mine to work.
I have to second RedHawk's comments here. I just tested my identical lens with a PK/A adapter and did not get good readings on the top LCD display until I cleaned the adapter contacts with eraser/alcohol combo.
02-11-2009, 06:08 PM   #13
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
QuoteOriginally posted by pentaxsteve Quote
yes it goes into AE by pressing the black tab..but no i still get don't get an aperture value nor any aperture noise
Sometimes Adaptall PK/A adapter need a fix as described in the "Fixing Tamron Adaptall P/KA Adapter" article.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
90mm, k-mount, lens, macro, pentax ist ds, pentax lens, slr lens, sp, tamron, tamron 90mm sp
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help using Tamron 90mm macro lens! catastrophe Troubleshooting and Beginner Help 15 10-28-2010 04:24 AM
For Sale - Sold: Tamron 90mm Macro Lens and Pentax 540 FGZ flash jumbuc Sold Items 3 04-25-2010 05:46 AM
For Sale - Sold: Pentax K100d + 18-55mm + Tamron 70-300mm; Tamron 90mm Macro jake123 Sold Items 4 11-09-2009 12:51 PM
For Sale - Sold: Pentax Film bodies, MF lens: Zenitar 16mm, Tamron 90mm macro SuperAkuma Sold Items 2 10-12-2009 02:22 AM
PENTAX K-A TAMRON SP 90mm F:2.5 MACRO 1:2 LENS FHPhotographer Pentax SLR Lens Discussion 3 12-10-2008 07:56 AM



All times are GMT -7. The time now is 12:00 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top