Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-24-2012, 11:56 AM   #1
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 874
My Sigma 70-200mm 2.8 has stopped autofocusing

Hi all,

I have a Sigma 70-200mm 2.8 II APO DG MACRO HSM that recently stopped autofocusing. Tried it on a different body as well, and got the same problem. I bought it from a forum member here in 2010. He is from Canada, and I am in the U.S. The box has a sticker on it saying that the lens has a 10 year Canada warranty. Given that it was bought in Canada and sold to me in the U.S., is this warranty applicable to me at all? I have contacted the seller here to see if he has the receipt or any other info for me.

If there is no warranty, do I just contact Sigma here in the U.S. to get an estimate for repair? Has anyone had any experience with Sigma repair in the U.S.? I'm trying to figure out a ballpark for how much it will cost and how long it will take. Thanks for any help or information anyone could provide!

01-24-2012, 12:12 PM   #2
Veteran Member




Join Date: Mar 2009
Location: Ohio, USA/ India
Photos: Gallery
Posts: 474
Sorry that this happened to your lens. I recall reading a recent positive experience with Sigma warranty by dadipentak (one of our forum members). Maybe he can post details?

Edit: found the link: https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/166251-sigma-service-rocks.html
01-24-2012, 12:58 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,091
That's the version that doesn't do HSM on Pentax camera, right? Have you tried cleaning the contacts? Chances are that it's easily fixable, so I would try to get the warranty to cover it. You'd need someone in Canada to help you with the shipping, though, as I believe the warranty service will only ship it inside Canada.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-24-2012, 01:09 PM   #4
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 874
Original Poster
QuoteOriginally posted by mccarvindh Quote
Sorry that this happened to your lens. I recall reading a recent positive experience with Sigma warranty by dadipentak (one of our forum members). Maybe he can post details?

Edit: found the link: https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/166251-sigma-service-rocks.html
That's an encouraging story, thanks!

01-24-2012, 01:11 PM   #5
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 874
Original Poster
QuoteOriginally posted by Adam Quote
That's the version that doesn't do HSM on Pentax camera, right? Have you tried cleaning the contacts? Chances are that it's easily fixable, so I would try to get the warranty to cover it. You'd need someone in Canada to help you with the shipping, though, as I believe the warranty service will only ship it inside Canada.
It does do HSM on Pentax. It has been working fine for over a year since I bought it, just stopped focusing at all recently. I did try and clean off the contacts, didn't work though, thanks for the tip.
01-25-2012, 10:37 AM   #6
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 874
Original Poster
Well, the person I bought the lens from does not have the receipt. I'm thinking, if the lens was introduced in 2007, and has a 10 year warranty, then would a receipt be needed to prove it's still in the warranty period? I guess it's Sigma in Canada that I should contact? Is there something on the lens that would indicate that it should be covered under a Canadian warranty? As I said earlier though, I don't know if being in the U.S. voids that. Doing a quick Google check seemed to indicate that the Sigma warranty for this lens would be 4 years in the U.S.?

Any suggestions?
01-25-2012, 03:13 PM   #7
Senior Member




Join Date: Jul 2009
Location: Perth, Australia
Posts: 180
I don't mean to sound condescending, but have you checked your camera isn't in MF mode?

I know when I had my Sigma 50-500mm, the MF/AF push/pull switch used to sometimes lock up. I would then have massive issues with AF.

Try putting the lens into MF/AF a couple of times and see if that fixes it. While in MF, rotate the focus from lock to lock and then but the lens back into AF mode. You should hear the AF motor click in when rotating the focus ring (when going from MF to AF).

Hope I made sense
01-25-2012, 03:38 PM   #8
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 874
Original Poster
QuoteOriginally posted by CrazyNuts Quote
I don't mean to sound condescending, but have you checked your camera isn't in MF mode?

I know when I had my Sigma 50-500mm, the MF/AF push/pull switch used to sometimes lock up. I would then have massive issues with AF.

Try putting the lens into MF/AF a couple of times and see if that fixes it. While in MF, rotate the focus from lock to lock and then but the lens back into AF mode. You should hear the AF motor click in when rotating the focus ring (when going from MF to AF).

Hope I made sense
Hi, thanks for the suggestion. Yes, I've checked everything I can think of to make sure it wasn't a wrong setting somewhere. Moved that switch back and forth many times. Can't say that I rotated the focus ring all the way around. I'll try that, but I think it's hosed. It's my only lens with SDM/HSM, loved that quiet focusing, just a little TOO quiet now!

01-25-2012, 05:17 PM   #9
Loyal Site Supporter
dadipentak's Avatar

Join Date: Jul 2008
Location: Baltimore, Maryland
Photos: Gallery
Posts: 10,406
QuoteOriginally posted by mccarvindh Quote
Sorry that this happened to your lens. I recall reading a recent positive experience with Sigma warranty by dadipentak (one of our forum members). Maybe he can post details?

Edit: found the link: https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/166251-sigma-service-rocks.html
As I indicated in that post, I've been pleased by the Sigma warranty service--especially in that particular case. They also did a great job calibrating my 50-150/2.8 for the K-5.. However, I had the same problem as the OP with my 70-200/2.8 II APO DG MACRO HSM and I have to say the outcome was not quite as good. The first time I sent it in, it came back working fine and sharper than ever. But then (about a year later and after my enthusiastic post about the 1-300/4), it developed some quirks (focuses fine most of the time but occasionally gets very slow and sometimes won't focus on the subject at all until I focus on something else first and then come back to the subject) and their attempts to fix that have not been completely successful. I put the issue aside a couple of months ago but really need to pursue it further.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
70-200mm, autofocusing, canada, k-mount, pentax lens, repair, sigma, sigma 70-200mm, slr lens, u.s, u.s., warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fastest autofocusing lens? lurchlarson Pentax SLR Lens Discussion 20 01-20-2016 12:27 AM
K20 stopped working with Sigma HSM DaveshootPentax Pentax DSLR Discussion 4 06-25-2010 04:18 AM
FA* 80-200mm/2.8 stopped working :((( HELP!!!!!!!! luke0622 Pentax SLR Lens Discussion 10 01-09-2010 07:29 AM



All times are GMT -7. The time now is 05:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top