Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-11-2012, 07:22 PM   #1
Veteran Member




Join Date: Jan 2011
Photos: Albums
Posts: 412
Need help with debug menu!

I'm trying to get into the debug menu on the k-x, but it's just not working. I hold the exposure compensation button while turning on, and it powers up as normal. I've read the other main threads here, even downloaded a file provided in one and it's still not working. What the heck am I doing wrong? Or has debug been deactivated with firmware 1.02? I drag and dropped the file directly onto the sd card, formatted in camera beforehand. I also don't understand this CR/LF business. The directions on the internet are pretty ambiguous for someone who doesn't know what this is or how to use it.


Last edited by outsider; 02-11-2012 at 07:27 PM.
02-11-2012, 07:24 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,714
I'm not 100% sure but I think this the firmware patch blocked debug more.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-11-2012, 08:39 PM   #3
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
Check this site out if you haven't already. Several have said that it works with FW 1.02. Make sure the file is loaded on your SD card at the root menu and not placed inside a folder.
---->HERE

Hope this helps. I never upgraded my Kx. I just noticed I am using 1.01.

Mark
02-11-2012, 08:42 PM   #4
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
You can download the correct file from this (in)famous Pentaxian Blogger. I have been using the Modset he created that you place on the card.

02-11-2012, 09:00 PM   #5
Veteran Member




Join Date: Jan 2011
Photos: Albums
Posts: 412
Original Poster
QuoteOriginally posted by MSM Quote
Check this site out if you haven't already. Several have said that it works with FW 1.02. Make sure the file is loaded on your SD card at the root menu and not placed inside a folder.
---->HERE

Hope this helps. I never upgraded my Kx. I just noticed I am using 1.01.

Mark
Thanks for the help. I've been on that site earlier today and the link to the file is dead. I found a file here on pentaxforums, drag and dropped it onto the card and followed the steps, but no debug comes up. i'll keep trying until i can confirm that pentax locked us out of debug with firmware 1.02
02-11-2012, 09:09 PM   #6
Veteran Member




Join Date: Jan 2011
Photos: Albums
Posts: 412
Original Poster
QuoteOriginally posted by MSM Quote
You can download the correct file from this (in)famous Pentaxian Blogger. I have been using the Modset he created that you place on the card.
"line must end with CR/LF" what does this mean? Does it mean we literally put this at the end of [OPEN_DEBUG_MENU] ?? space or no space? Eh?
02-11-2012, 10:00 PM   #7
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
I believe CR= Carriage Return (ie enter).IIRC after you finish typing you have to press the return key. The truth is I just went to that link and downloaded his file from the site and did nothing but place it on a formatted SD card at the root level and it worked. His instructions are good too. In fact between posts, I was just reevaluating my Kx. Mine need adjustment of +110! (in fairness to Pentax, I did drop my camera once.) Good luck. Let me know if this helps.

Mark
02-11-2012, 10:02 PM   #8
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
I keep the file on a separate 64 Mb card (Classic) that I can pop in anytime to have a check. I think I finally have it where I need it. I find that getting a good set up is difficult to test because of the variables.

02-11-2012, 10:21 PM   #9
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
Outsider I sent you a PM
02-12-2012, 11:20 AM   #10
Veteran Member




Join Date: Jan 2011
Photos: Albums
Posts: 412
Original Poster
QuoteOriginally posted by MSM Quote
Outsider I sent you a PM
Eureka!!! Bygolly it worked. Not only did it work, it worked like a charm! Took a while of testing and adjusting (about 1.5 hours) of testing, adjusting and testing again, using a few different backrounds to get it where it should be, but it now focuses within a frogs hair of where it should be at F 1.4!!! I'll take your advice and keep the file on a separate card and use it when needed. I think some k-x settings "forget" themselves if you leave it without batteries for an extended time, hopefully the AF adjustment isn't one of them. Cheers!
02-15-2012, 08:01 AM   #11
MSM
Veteran Member
MSM's Avatar

Join Date: Dec 2007
Location: Alabama
Photos: Gallery
Posts: 994
Awesome, Outsider. I am glad it worked for you! I mentioned that I was making adjustments to my Kx when I saw your post. I wanted to help a brother out. I know what a difference it makes. I had adjusted it in the past but I don't think I tweaked it enough. Now I am about +110. It made enough difference that I feel that I can curb my desire to upgrade. (well almost!)

Mark
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
debug, file, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debug menu for *ist DS v2.01+ jfsavage Pentax DSLR Discussion 6 12-13-2012 01:52 PM
Debug menu access for the K100DS? Nachodog Pentax DSLR Discussion 3 04-14-2010 02:27 PM
Anyone know if 'debug' menu is available for Nikon cameras? jsherman999 Non-Pentax Cameras: Canon, Nikon, etc. 2 12-18-2009 07:07 PM
K10d-debug menu-IR possible? Bokeh Pentax DSLR Discussion 6 05-17-2008 05:54 PM
K100D Super Debug menu joelw135 Pentax DSLR Discussion 9 10-18-2007 04:23 AM



All times are GMT -7. The time now is 10:26 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top