Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-14-2012, 07:06 AM   #1
Forum Member




Join Date: Feb 2011
Location: Surrey
Photos: Gallery
Posts: 70
Problem with FA43

My 43 suddenly stopped working on my K5 body. When mounted " F-----". I wiped both sets of contacts, any other suggestions please?

03-14-2012, 07:15 AM   #2
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,806
is the aperture on the lens body set to A?
03-14-2012, 07:16 AM   #3
Loyal Site Supporter
eddie1960's Avatar

Join Date: Aug 2010
Location: Toronto
Photos: Gallery | Albums
Posts: 12,264
QuoteOriginally posted by blackcloudbrew Quote
is the aperture on the lens body set to A?
this would be my guess as well, off the A setting the camera treats it like any pre A lens
03-14-2012, 07:25 AM   #4
Forum Member




Join Date: Feb 2011
Location: Surrey
Photos: Gallery
Posts: 70
Original Poster
Yay, this worked. I had it set all the way up the other end at 1.9 Don't know how I managed to do that. Thanks very much both of you

03-14-2012, 07:32 AM   #5
Pentaxian




Join Date: Nov 2011
Photos: Gallery | Albums
Posts: 3,706
QuoteOriginally posted by sworks Quote
Don't know how I managed to do that.
Grabbed the aperture ring when you mounted the lens?
03-14-2012, 07:49 AM   #6
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,806
Been there done that too.
03-14-2012, 02:29 PM   #7
Forum Member




Join Date: Feb 2011
Location: Surrey
Photos: Gallery
Posts: 70
Original Poster
Ooops, maybe Learn't something new though!
03-14-2012, 03:35 PM - 1 Like   #8
Col
Veteran Member
Col's Avatar

Join Date: Apr 2007
Location: Stansted Essex
Photos: Gallery
Posts: 615
QuoteOriginally posted by sworks Quote
Ooops, maybe Learn't something new though!
Yeah but 4 months later you'll forget, panic for about 5 minutes then quietly move the aperture ring back to 'A' and look around to see if anyone had spotted you sweating it. How much safer is the DA series?

ps. I actually did that in front of the salesman when I tried (the now) my FA43 just last month. He almost lost the sale due to my chagrin

03-15-2012, 04:44 PM   #9
Forum Member




Join Date: Feb 2011
Location: Surrey
Photos: Gallery
Posts: 70
Original Poster
I should probably take my specs from the top of my head and place them on my nose, then I might have noticed what I was doing!!! Probably would've been just as dismayed though as I had no idea what the "A" was for!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
FA43 Frustration jaieger Pentax SLR Lens Discussion 7 06-15-2011 01:33 PM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Persuade me to get a FA43?! yyyzzz Pentax SLR Lens Discussion 38 10-24-2010 09:29 AM
AF speed of K-x + FA43? switters Pentax SLR Lens Discussion 7 04-11-2010 08:09 AM
FA43 focus problem at f/2.8 Kguru Pentax SLR Lens Discussion 9 09-18-2007 07:03 AM



All times are GMT -7. The time now is 10:30 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top