Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-04-2012, 11:12 AM   #1
Site Supporter
Site Supporter
germar's Avatar

Join Date: Apr 2007
Location: Austin Texas
Photos: Gallery
Posts: 728
C.R.I.S. "Parts hold-backorder" how long?

Hey, all...

I've got my DA* 16-50 in for repair with C.R.I.S for a dead AF motor. My job has just gone under "Parts hold-backorder" which means they're waiting for parts "from the factory." I'm used to "backorder" meaning a very, very long delay in ever getting my lens back. Has anyone experienced this deep freeze from C.R.I.S recently and how long did the delay take over the original 15-20 day turnaround promise? I'm trying to decide if I need to rent a lens for an upcoming early June vacation. My thanks.

04-04-2012, 11:41 AM   #2
Site Supporter
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,915
You should ask CRIS directly. We would only be guessing, and each situation is different.

Last edited by SpecialK; 04-05-2012 at 12:13 AM.
04-04-2012, 11:59 AM   #3
Site Supporter
Site Supporter
germar's Avatar

Join Date: Apr 2007
Location: Austin Texas
Photos: Gallery
Posts: 728
Original Poster
QuoteOriginally posted by SpecialK Quote
You ask CRIS directly. We would only be guessing, and each situation is different.
Thanks, I will ask them. I guess I was looking for someone here that might have experienced a similar delay. Someone with a real life experience would be helpful, I think.

-Edit-

For what its worth, the reply from C.R.I.S. was pretty much what I expected: "Don't know, we're waiting on Japan. Ask again later."

Last edited by germar; 04-04-2012 at 12:27 PM. Reason: Additional info
04-04-2012, 02:09 PM   #4
Veteran Member
UpNorth's Avatar

Join Date: Jan 2009
Location: Minnesota, U.S.A.
Photos: Gallery | Albums
Posts: 708
If this helps at all - They had my K20D at the end of last summer, and were waiting for a circuit board while giving me the same message. From the time they received it until the time they shipped it back (fixed - and it's been working great ever since), it was within a day or two one way or the other of 7 weeks. Of course that felt like 7 months - but it was "out of their control". Apparently the boat from Japan is REALLY slow.....

Tim

04-04-2012, 02:23 PM   #5
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 25,877
I went through the same with our 21 ltd... Pentax Canada told me the part had to come from Japan. It was maybe 6 weeks. We were hoping to get it back for Chrismas. We got word the part was needed on Dec.20 or thereabouts. We got the lens back Feb. 8.
04-04-2012, 02:56 PM   #6
Pentaxian




Join Date: Mar 2010
Location: SW Washington
Posts: 820
When I had my 60-250 sent into CRIS, they put me on "Parts Hold Backorder" twice because they did not find all the problems the first time.

Each "Parts Hold Backorder": 2 months
Total time in "repair": Exactly 5 months from arrival at CRIS to shipment back to me

Last edited by Cannikin; 04-04-2012 at 03:04 PM.
04-04-2012, 04:45 PM   #7
Site Supporter
Site Supporter
germar's Avatar

Join Date: Apr 2007
Location: Austin Texas
Photos: Gallery
Posts: 728
Original Poster
Extremely helpful feedback, I very much appreciate it. Looks like I'm renting a lens at the end of next month! Cheers and thank you.

germar
05-03-2012, 04:11 PM   #8
Site Supporter
Site Supporter
germar's Avatar

Join Date: Apr 2007
Location: Austin Texas
Photos: Gallery
Posts: 728
Original Poster
Wrapping up the thread.

Just to wrap up this thread, the lens has arrived back today, May 3rd. I shipped it March 23rd, so roughly 6 weeks to get the lens repaired. Not great, but not as bad as it could have been.

05-04-2012, 04:11 PM   #9
Veteran Member
Lloydy's Avatar

Join Date: Aug 2007
Location: Shropshire, UK
Posts: 1,114
Parts are slow in the UK right now, my K10 has been in for repair and waiting for a viewfinder LCD display for nearly 5 weeks now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
delay, k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Don't say Pentax "Q" in French ... "Q" = "cul" = "A--" Jean Poitiers Pentax Q 52 11-10-2013 06:25 AM
Any side effect for using live view for "too long"? (viewfinder hood) telly0050 Pentax K-5 12 01-23-2012 05:28 AM
PayPal+eBay+Adorama - transaction is "Temporary Hold" Neco General Talk 12 11-01-2010 07:54 PM
"Hey, hold my beer ... watch this!" J.Scott Post Your Photos! 2 09-12-2008 09:22 AM
Pentax Gallery "On Hold" tag wmmk Photographic Technique 9 04-20-2007 03:32 PM



All times are GMT -7. The time now is 12:08 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top