Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-13-2013, 08:38 PM   #16
New Member
xnau's Avatar

Join Date: Aug 2012
Photos: Albums
Posts: 8
Sorry for resurrecting a year-old thread, but I just purchased a Vivitar 70-210 4.5 P/K with the long shield as described here. I found it at a Goodwill store for $30. I removed the ring with the shield just to see if I wanted to keep it and although it did mount OK, the shutter release is affected. When I depress the shutter, the mirror flips up and stays there, no exposure happens. If you rotate the f-stop ring, the mirror does flip back down.

Anybody have an idea what might be happening or if it's possible to modify the lens to prevent this?

thanks

06-14-2013, 03:16 AM   #17
Site Supporter
Stone G.'s Avatar

Join Date: Jun 2010
Location: North Zealand, Denmark
Photos: Gallery | Albums
Posts: 1,511
Weird behaviour. I would suspect the lens itself to have a flaw. You might try this:

1. Mounted on your DSLR, does the aperture stop down as it should, when the mirror flips up?

2. Mounted on an old Pentax SLR (they might have one in the same store if you don't have your own) with the "shield-ring" in place, does that combination behave as it should?

If either isn't the case, I would assume that the lens is faulty and that the camera waits for the aperture coupling lever to engage (or-something-like-that).

I trust that you do have the camera in manual mode.
06-14-2013, 07:55 AM   #18
New Member
xnau's Avatar

Join Date: Aug 2012
Photos: Albums
Posts: 8
Thanks, yeah, it's in manual mode. I've got a thing for old primes. After your comment, I wondered if the linkage wasn't engaging or was jammed. I looked more closely at the linkage and although the iris closed easily on the lens, it seemed to be slightly bent. It straightened it out and voila! Works! Thanks for pointing me in the right direction.

Now I get to see whether it was a good bargain or not...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-5, k-mount, lens, mount, p/k, pentax lens, slr lens, vivitar
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
67 II 400mm f4 lens mounting issue mkppentax Pentax Medium Format 4 05-03-2012 10:13 PM
mounting sigma lens to pentax kx mikesgarage Troubleshooting and Beginner Help 7 12-06-2011 01:12 AM
Mounting a M42 lens to my K-x olivemike Troubleshooting and Beginner Help 5 04-09-2011 06:23 PM
Help Mounting Vivitar 100-300mm Yale Quan Pentax SLR Lens Discussion 5 10-13-2008 11:13 PM



All times are GMT -7. The time now is 12:25 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top