Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-27-2012, 08:08 PM   #1
New Member




Join Date: May 2011
Location: Florida
Posts: 3
Please help

I was given a Pentax PK Mount Sears Auto 50mm f2 wide angle prime lens, and I cannot seem to figure out why when I put it on my K-r it won't shoot a picture. Do I need an adapter for it or am I doing something else wrong? Any help would be appreciated... But please dumb it down for me I'm new to photography.

07-27-2012, 08:17 PM   #2
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,311
https://www.pentaxforums.com/forums/pentax-beginners-corner-q/110658-using-ma...x-dslrs-f.html
07-27-2012, 08:17 PM   #3
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,896
I believe there is a setting you need to turn on or off in your camera to get it to work. I have never shot with a manual lens before so I have no idea what to do. Someone here who has shot with such lens can help you out, hopefully soon... Sorry I can't be of any help =(

EDIT: Someone posted before me =)
07-27-2012, 08:37 PM   #4
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,002
Take a look at the instructions in your manual page 314, or you can download the manual here...


07-27-2012, 11:21 PM   #5
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
The thread in the Beginner's will get you shooting, but note there is nothing remotely wide about a 50mm lens on your camera. It's a (short) telephoto.

Last edited by Marc Sabatella; 07-30-2012 at 06:31 PM.
07-29-2012, 09:47 AM   #6
New Member




Join Date: May 2011
Location: Florida
Posts: 3
Original Poster
There is not an "A" setting on this lens. It fits perfectly in my camera, it just doesn't compute sigh
07-29-2012, 10:00 AM   #7
Pentaxian
bluestringer's Avatar

Join Date: Nov 2011
Location: Cotton fields of South Georgia
Photos: Gallery | Albums
Posts: 2,402
QuoteOriginally posted by Mayer1978 Quote
There is not an "A" setting on this lens. It fits perfectly in my camera, it just doesn't compute sigh

It's a manual lens, you have to set the aperture on the lens, use green button metering to set exposure. You first have to set aperture permitted to yes in the custom settings of the menu.
07-30-2012, 06:31 PM   #8
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
QuoteOriginally posted by Mayer1978 Quote
There is not an "A" setting on this lens. It fits perfectly in my camera, it just doesn't compute sigh
Did you click the link in the first response to your question? It's a very detailed article that explains in detail how to use manual lenses.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
help, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My autofocus is broken? Please Help! marius Pentax DSLR Discussion 5 08-13-2010 05:30 AM
Please help - I've deleted all my holiday photos ! :O( Adrian William Photographic Technique 10 08-09-2010 04:29 PM
i'm confused Abi Nic Troubleshooting and Beginner Help 7 08-09-2010 01:06 PM
Please help: K7 banding issue kytra Pentax DSLR Discussion 9 08-04-2010 12:10 AM



All times are GMT -7. The time now is 06:20 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top