Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-23-2012, 04:37 AM   #1
New Member




Join Date: Jul 2012
Photos: Gallery
Posts: 14
loose DoF ring on Chinon 50mm f/1.7

I've got a Chinon Auto 50mm f/1.7 off ebay and whilst it looks quite clean the DoF ring, which also indicates the aperture setting, is loose and just rotates.

How can I fix this ?

Does it need to be dismantled or will simply a drop of glue be OK ?

Peter

08-23-2012, 12:35 PM   #2
Veteran Member




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
QuoteOriginally posted by peedeecee Quote
I've got a Chinon Auto 50mm f/1.7 off ebay and whilst it looks quite clean the DoF ring, which also indicates the aperture setting, is loose and just rotates.

How can I fix this ?

Does it need to be dismantled or will simply a drop of glue be OK ?

Peter
First, it's called an aperture ring not a DOF ring. Your description seem to indicate the aperture blades do not move when the aperture ring is turned - I suspect the lens was taken apart previously in an attempt to fix the stuck aperture blades (unsuccessful) and put back together without the detent stop ball/spring parts. Return the lens and get your money back, no point in trying fix somebody else' screw-up.
08-23-2012, 12:43 PM   #3
Veteran Member
kcobain1992's Avatar

Join Date: Dec 2010
Location: Bucharest, Romania
Photos: Gallery
Posts: 1,409
A drop of glue is definitely NOT ok.
I believe there is more than one version of the Chinon 50/1.7, so a picture or more would be very helpful. I can't tell about your lens, but I had this specific problem on 2 of my Takumars and it was just a matter of 3 set screws being loose (accessible from the outside with the proper screwdriver, no disassembly required).
08-23-2012, 01:05 PM   #4
New Member




Join Date: Jul 2012
Photos: Gallery
Posts: 14
Original Poster
Thanks for your 2 comments.

Firstly, it is NOT the Aperture ring that is loose. That works perfectly, with 1/2 stop detents and the aperture blades move perfectly smoothly.

Looking at some other threads I believe some people call it the Focus Guide ring but whatever, it has the DoF markings from 0 to 22 either side of the central aperture set point indicator.

Secondly, on THIS lens there are NO screws visible (as on the Taks) so it looks like theses screws must be hidden beneath the Aperture ring behind it (i.e. the ring nearest to the K mount flange)

This lens came on a Chinon CE-4s and is the "AUTO CHINON MULTI-COATED 1:1.7 50mmm JAPAN 49dia" which can be seen in the Third Party Lens reviews section of this website at https://www.pentaxforums.com/userreviews/chinon-auto-mc-50mm-f-1-7.htm

I guess I would need to remove the K mount flange and the rear element to find how this loose ring should be secured ?

I got another of these lenses around the same time and that one is fine so I'm quite happy to experiment on THIS one.
It would cost more to return it than I paid for it (complete with the camera)!!!

Peter

08-24-2012, 01:42 AM   #5
Veteran Member
Lloydy's Avatar

Join Date: Aug 2007
Location: Shropshire, UK
Posts: 1,114
From memory, I think you're right and the only way to secure the ring is to remove the mount and the aperture ring, I don't think the rear elements need to be disturbed though

It's a great lens.
08-24-2012, 03:18 AM   #6
New Member




Join Date: Jul 2012
Photos: Gallery
Posts: 14
Original Poster
QuoteOriginally posted by Lloydy Quote
From memory, I think you're right and the only way to secure the ring is to remove the mount and the aperture ring, I don't think the rear elements need to be disturbed though

It's a great lens.
Many thanks.

My problem now is HOW to get the mount off ?

I've tried loosening the 5 small 'phillips' screws with a Maplin precision screwdriver but they are VERY VERY tight !

Should I try the old 'car mechanic's' trick of a light hammer blow or is a solvent needed to soften some glue ?

Any help would be much appreciated as I'd like to restore this lens.
As you say, all the reports on this lens are very favourable.

Thanks again

Peter
08-24-2012, 04:39 AM   #7
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
QuoteOriginally posted by peedeecee Quote
I've tried loosening the 5 small 'phillips' screws with a Maplin precision screwdriver but they are VERY VERY tight !
Try this: heat the screws with the tip of a soldering iron. It may take several cycles of heated up/cooling down for the screws to break loose.
08-24-2012, 04:55 AM   #8
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,869
QuoteOriginally posted by peedeecee Quote
My problem now is HOW to get the mount off ?

I've tried loosening the 5 small 'phillips' screws with a Maplin precision screwdriver but they are VERY VERY tight !
This is a Japanese made lens. Therefore the screws are not Phillips head. They are JIS.



08-24-2012, 07:56 AM   #9
New Member




Join Date: Jul 2012
Photos: Gallery
Posts: 14
Original Poster
Thanks for all your postings - job done !

In the end it just needed some carefully applied 'brute force' on the screws - the kind of pressure on the handle that leaves red marks in the palm of your hand !

Once the flange was off the Aperture ring simply slid off, revealing 3 tiny slot head set scews which should fix the DoF ring - they were all loose, of course !

Simply tightened these set screws (after aligning the '0' with 22 after closing the aperture down), replaced the aperture ring and the K-mount flange and all was back in full working order !

Now I'm off to test the lens !

I hope this helps anyone else who comes later looking for help ?

Peter
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, chinon, dof, f/1.7, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing the front ring of the 50mm 1.7 Auto Chinon Penumbra Pentax SLR Lens Discussion 4 05-25-2011 01:30 AM
SMC Pentax-M f1.4 50mm loose front ring? theperception2008 Pentax SLR Lens Discussion 6 05-04-2011 08:06 PM
Loose focus/zoom ring. Should I return it? cerebrate Pentax SLR Lens Discussion 11 03-22-2011 04:20 PM
Loose distance scale ring on Super Tak 105/2.8 Swift1 Pentax SLR Lens Discussion 2 10-17-2010 10:39 AM
Tamron 17-50mm/2.8 Loose Filter Ring? Venturi Pentax SLR Lens Discussion 4 06-18-2010 06:57 AM



All times are GMT -7. The time now is 03:41 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top