Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2012, 09:45 AM   #1
New Member




Join Date: Sep 2012
Location: Leipzig, Saxony, Germany
Posts: 6
Strange aperture behavior with used 17-50mm Tamron

HI,

I received today an used Tamron 17-50/2.8 from a Nikon user. He got this lens from eBay thinking it was the right version for him, because it got a Nikon lens cap. Anyway lets get back to topic:

This 17-50 got an strange behavior, it seems to close the aperture not right. f4 is -0.3EV from f2.8, f5.6 -1EV, f8 -2EV, f11 -3EV and so on.

First i thought it would be the blades, who need to much force to close. But checking the lever on the lens manually, resulted in a smooth and easy to control aperture lever. Cleaning the contacts didn't help either.

Does someone here know something about this problem? It didn't seem that popular, because google and forum search resulted only in other kinds of aperture problems.

Your help is greatly appreciated.

09-22-2012, 10:00 AM   #2
Veteran Member




Join Date: Dec 2009
Location: Deep Forest
Posts: 630
Is that a full frame lens on a crop camera?

Full frame lens wide open crop cam meter reads too high.

Besides Manual mode, workaround is to set EV compensation to average value over aperture range used.
09-24-2012, 01:13 AM   #3
New Member




Join Date: Sep 2012
Location: Leipzig, Saxony, Germany
Posts: 6
Original Poster
QuoteOriginally posted by rhodopsin Quote
Is that a full frame lens on a crop camera?
There is no 17-50 who is fullframe capable.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, aperture behavior, behavior, k-mount, lens, lever, nikon, pentax lens, slr lens, tamron
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange K-r behavior kcobain1992 Pentax K-r 11 09-20-2011 01:42 PM
K-r strange behavior? kostadinov Pentax K-r 3 02-19-2011 07:53 AM
K-5 strange behavior/firmware bug?? biphers Pentax K-5 21 01-18-2011 09:36 AM
K20d strange behavior zlorfik Troubleshooting and Beginner Help 4 01-17-2011 01:18 PM
K-5 strange behavior / bugs? limbonaut Pentax K-5 3 11-21-2010 10:26 PM



All times are GMT -7. The time now is 04:07 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top