Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-09-2013, 07:17 PM   #1
Junior Member
primo's Avatar

Join Date: Jan 2013
Location: Auburn, New York
Posts: 36
Used Sigma 15 FE does nothing on my K5IIs but partially works on K10 & K20...

I just received a used Sigma 15mm fish eye from eBay(320 shipped) today. After testing the lens on 3 cameras my 1st thought was to return it asap but I am able to produce good photos with my K10 and K20. With these 2 cameras the AF works and I can adjust the shutter speed in the usual way but can only adjust the f-stop manually using the clicker at the base of the lens.

The big disappointment and mystery to me is, that it does absolutely nothing on my K5IIs. The seller has 100% feedback says he's had it for five years and that it worked fine on his Kx and K20. I read on a previous thread that an original owner of a Sigma lens can get a 7 year extension on his warranty for $20. I imagine there is nothing available for a 3rd owner, right?

My guess is it's not worth to keep and send to Sigma for repairs, right? Any suggestions?

03-09-2013, 07:24 PM - 1 Like   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
Have you enabled use of the aperture ring through the custom function menu on your K-5?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-09-2013, 08:04 PM   #3
Junior Member
primo's Avatar

Join Date: Jan 2013
Location: Auburn, New York
Posts: 36
Original Poster
Thank you Adam! Yes I found it (#27) and now I am able to take photos with the K5 but still not able to adjust the fstop manually, is this normal for this lens? or is there another custom setting that I have not found?
03-09-2013, 08:10 PM   #4
Junior Member
primo's Avatar

Join Date: Jan 2013
Location: Auburn, New York
Posts: 36
Original Poster
QuoteOriginally posted by primo Quote
but still not able to adjust the fstop manually
Correction: I can adjust the fstop with the clicker ring at the base of the lens manually, but not using the traditional thumb scroller. Is this normal for this lens?

03-09-2013, 08:14 PM - 1 Like   #5
Site Supporter
K(s)evin's Avatar

Join Date: Sep 2010
Location: Colorado
Posts: 253
Is the lens in the "A" position?
03-09-2013, 08:15 PM   #6
Site Supporter
K(s)evin's Avatar

Join Date: Sep 2010
Location: Colorado
Posts: 253
On the aperture ring I mean.
03-09-2013, 08:17 PM   #7
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
You either turn the aperture ring manually, and put the camera in M mode, or you put the lens on 'A' and use the wheels on the body (and can use any shooting mode). With a properly functioning A lens, there is generally no reason to turn the ring manually. Just put it on A and leave it. Does it work then?
03-09-2013, 09:34 PM   #8
Junior Member
primo's Avatar

Join Date: Jan 2013
Location: Auburn, New York
Posts: 36
Original Poster
Yes K(s)evin, that solved the 2nd problem I had! I just checked all the lenses I own and never seen an A setting like that. Even though I'm still a newbie on the forum, I would have to say the advice on this thread alone was well worth a donation to Pentax Forms! Thank you Adam and K(s)evin!

03-10-2013, 02:36 PM   #9
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
QuoteOriginally posted by primo Quote
Thank you Adam! Yes I found it (#27) and now I am able to take photos with the K5 but still not able to adjust the fstop manually, is this normal for this lens? or is there another custom setting that I have not found?
Glad to hear we were able to help you! For future reference, a different procedure must be followed whenever the aperture ring isn't set to "A" (i.e. if the camera doesn't have an aperture ring). The instructions are found here:

https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html

Otherwise, just use the e-dials to adjust the aperture and/or shutter speed.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cameras, k-mount, k10, k20, k5iis, lens, owner, pentax lens, sigma, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2 cents results on K5IIs Rnovo Pentax K-5 7 11-30-2012 10:55 PM
Does the K-r AA battery holder works on K30? simbon4o Pentax K-30 & K-50 21 10-23-2012 09:06 AM
Pentax M Lens works on Kx? DA L lens works on Vivitar 2X Macro Teleconverter? Kenneth3aracing Pentax SLR Lens Discussion 6 05-06-2011 08:54 AM
used K10 VS used K20 MacKay Pentax DSLR Discussion 7 02-17-2010 11:23 PM
Memory card error -- works on PC but not on camera K7er Pentax DSLR Discussion 6 02-14-2010 11:33 PM



All times are GMT -7. The time now is 05:51 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top