Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-10-2013, 06:33 PM   #1
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Help, focus on 70-300 not working

Hello. As the title states I am having focusing issues with a Tamron 70-300mm I picked up from the PO Box today.
The lens is going on my relatively new K30 (also my first DSLR). Past about 150mm, auto focus doesn't lock on. The camera just keeps attempting to focus with no lock, even though the lens travels through what appears to be a focused point.
Manual focus works all the way out to 300mm.

Any ideas?

05-10-2013, 09:04 PM   #2
Veteran Member
manacho2005's Avatar

Join Date: Oct 2011
Location: Red Oak, TX
Photos: Gallery | Albums
Posts: 462
Does the image seem dark when viewed through he viewfinder? If so, the aperture blades may be stuck and the camera is having a hard time focusing due to the limited light.
Happened to me with a 70-300 sigma.
05-11-2013, 02:55 AM   #3
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 873
If I remember correctly the Tamron is not constant aperture.

Could it be that in the conditions you checked it in the smaller f-stop at the longer end just didn't allow enough light through for focus lock?
05-11-2013, 01:02 PM   #4
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
The image appears normal through the viewfinder. I can easily see the image focus as the camera hunts to lock a focus point.
I was unable to lock on to anything at 5.6. It was cloudy outside but at 2 in the afternoon, not terribly dark.

When fully zoomed, the camera allows me to select 4 for an aperture setting even though the lens should max out at 5.6 at 300mm. Perhaps my problem is connected somehow to this?

05-13-2013, 04:00 PM   #5
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
I checked today and the focusing works with live view. Still, no dice with the viewfinder.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
focus, k-mount, lens, lock, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
catch in focus not working steve7cat Visitors' Center 10 05-22-2013 08:27 AM
Disassembled Tamron 70-300 AF LD and now it's not working isumi Troubleshooting and Beginner Help 9 08-02-2012 08:58 AM
HELP! HELP! K5 not working/back from CRIS psychdoc Pentax K-5 118 10-19-2011 05:50 AM
K-r will not take photos, shutter button not working - HELP! seattledotcom Troubleshooting and Beginner Help 8 06-08-2011 04:19 PM
HELP - Pentax FA 100-300 f4.7 Lens not working in Av mode gut1kor Pentax SLR Lens Discussion 11 05-25-2011 07:02 PM



All times are GMT -7. The time now is 10:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top