Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-21-2013, 08:21 PM   #16
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
Bought mine new from B&H last year, non OS. I just tried it on both my Pentax bodies and it works great. Can you focus it manually? The loch is a switch on the side of the lens near the af/ mf switch. If the lens is defective , that sucks. I bought a new FA31 Ltd last summer and had to return it straight away. Hope you get this sorted out, it is a sweet lens.

06-21-2013, 08:27 PM   #17
Site Supporter




Join Date: Apr 2009
Location: San Francisco
Posts: 161
Original Poster
Yeah I can focus it manually np, but want AF. Need AF. hmmm I think it must be bad then. If you didnt change the chip in it, and it works fine then I am extra confused....

So far to summarize:
Tried on K01 and K200d, both it did not work with. Neither would focus
AF set on both body and lens
no AE button issues as far as assignments goes

reading that HSM needs an upgrade to be used with CDAF, not sure how true it is....contacted sigma to find out
reader above, says his is perfect with no need for that upgrade, maybe a newer model had that added in?

grrr
06-24-2013, 12:55 PM   #18
Site Supporter




Join Date: Apr 2009
Location: San Francisco
Posts: 161
Original Poster
For others to reference, I called Sigma and was going to cost me 170 to overnight out there, F that! 25 for a week delivery. So I decided to just return the lens and get another, hope that it fixes it.

The service guy for Sigma got really pissed when I told him that I heard that I needed to have a chip upgraded so that the lens would work with a CDAF system. He told me that all lenses use that system now and gets really pissed when he hears someone say "well i read on a blog..." yada yada.

So lets hope this lens works better than the last one!
06-24-2013, 09:03 PM   #19
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
Hope you get this sorted out, the 17-50 non OS is a stunning lens. So much better than what I expected.

06-25-2013, 10:54 AM   #20
Site Supporter




Join Date: Apr 2009
Location: San Francisco
Posts: 161
Original Poster
Due to arrive tomorrow, I'll of course update, and then cry if it doesn't work. I was pretty blown away that Adorama would send a 700 dollar lens in just a bubble envelope.
06-25-2013, 10:59 AM   #21
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
Try the lens on a different Pentax camera if possible.
If it works on the other camera, maybe the K-01 doesn't have that lens included in its firmware yet - wild guess!?

If it still doesn't, maybe you have a problem with the lens - return and try another brand.


...

Oups... didn't read till the end... sorry.
06-25-2013, 04:59 PM   #22
Veteran Member




Join Date: Jul 2009
Location: Mount Joy, PA
Photos: Gallery | Albums
Posts: 533
QuoteOriginally posted by rzarector Quote
Due to arrive tomorrow, I'll of course update, and then cry if it doesn't work. I was pretty blown away that Adorama would send a 700 dollar lens in just a bubble envelope.
What?! Are you saying when you originally purchased the lens it arrived in a bubble envelope, rather than a box with packing material? I've heard of a few people getting camera accessories in envelopes rather than boxes, which while not ideal, didn't ruin anything. However, if you got a lens in an envelope I'm not surprised you're having trouble.

I didn't read anywhere in the thread how long you've owned the lens. Is this brand new? If it is I would have sent it back to Adorama.
06-25-2013, 07:52 PM   #23
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
Bubble wrap? WTF, that is bush league....I would have sent it back for that reason alone. You probably got someone else's problem and it's no wonder it wasn't right. Good to know, I'll avoid ADorama for any future purchases and stick with B&H or Prodigital2000. Good luck with the replacement lens.

06-25-2013, 09:11 PM   #24
Moderator
Racer X 69's Avatar

Join Date: Jun 2010
Location: The Great Pacific Northwet
Photos: Gallery | Albums
Posts: 10,791
QuoteOriginally posted by rzarector Quote
Due to arrive tomorrow, I'll of course update, and then cry if it doesn't work. I was pretty blown away that Adorama would send a 700 dollar lens in just a bubble envelope.
The issue of Adorama shipping camera lenses in a bubble envelope has come up here before. Helen from Adorama is a member here, and helps with issues such as this. I seem, to remember she had worked to resolve just this very situation with another forum member here.

Here it is: https://www.pentaxforums.com/forums/general-photography-industry/222631-my-re...ml#post2361629
06-25-2013, 11:35 PM   #25
Site Supporter
vagrant10's Avatar

Join Date: May 2007
Location: portland
Photos: Albums
Posts: 1,361
I remember when Sigma was selling the last of their 50-150's people found out that for it to work on their k01, they had to send the lens back to Sigma. Try calling their customer service again and hopefully you won't get someone who gets spun up so easily. I'd leave them to draw the conclusions though and not say "I read on the internet..." very much, if at all.
06-26-2013, 02:02 PM   #26
Site Supporter




Join Date: Apr 2009
Location: San Francisco
Posts: 161
Original Poster
Yeah that is what I read too but the lens came out before 2012, and others posted the lens worked perfectly on first use. It arrives shortly so we shall see. If this lens has the same issue then maybe the firmware is the issue, but the guy I spoke to at Sigma says that its "horse shit." All cameras for years have been HSM ready. but I dont know....
06-26-2013, 08:06 PM   #27
Site Supporter




Join Date: Apr 2009
Location: San Francisco
Posts: 161
Original Poster
OK FOLKS! PROBLEM SOLVED!

I got the 2nd lens today in a BOX and with BUBBLE WRAP!!! MUCH BETTER. Funny how that happens.

Lens out the box was perfect. just perfect. Snappy, clear, no focus issues at all. Love love love it.
Attached Images
View Picture EXIF
PENTAX K-01  Photo 
06-27-2013, 09:58 AM   #28
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
Enjoy!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
focus, k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanna help me spend my budget? Would you buy a lens on preorder? Sigma 17-50 vs 17-70 haycyn Pentax SLR Lens Discussion 8 05-22-2013 09:15 AM
Debating between Sigma 17-50 mm, Tamron 17-50mm, Tamron 28-75mm, Tokina 16-50 babaloohead Pentax SLR Lens Discussion 25 03-23-2013 08:56 AM
Test Driving My New Sigma 17-50 f2.8 aussiegal Pentax SLR Lens Discussion 7 03-10-2013 06:06 PM
HELP I can't get my 50 off my macro teleconverter! shaolen Troubleshooting and Beginner Help 2 07-21-2012 09:20 PM
Sigma pricing on new 17-50 G_Money Pentax SLR Lens Discussion 5 12-02-2011 07:47 PM



All times are GMT -7. The time now is 08:30 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top