Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-25-2013, 04:49 AM   #1
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,768
Focussing problem Sigma EX 70-200mm 1:2.8 II MACRO HSM

Argh.

My favourite lens returned from its second repair under warranty last week. All good Thursday, all good Friday, mental note to self to send message to Australian distributors CR Kennedy thanking them for their service. Took the lens to Ballarat on a cold and foggy Saturday morning. Total failure once more.

The first fault was a total failure of the HSM.
Second fault was failure of HSM to focus on anything above 40 metres away. This time they fixed the stiff manual focusing ring as well.
Third and current fault total failure of HSM.

Are these things really delicate or have I just got a bum copy? Could it possibly be something in my K-7 that is blowing it up?

Ah well back to CR Kennedy again next week. They are nice people there but I really don't want to see them again.

08-25-2013, 07:46 AM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,849
Sorry to hear of your hassles.
Never had a problem with mine, touch wood, whether at a rodeo or a gig, or on the K-x or the K-5.

Always make sure it is mounted properly and carefully, and the pins are clean on the mount though. Another Sigma lens of mine would sometimes give me problems when I didn't pay particular attention to those issues.
08-25-2013, 09:05 AM   #3
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,533
Sorry to hear your problems. As mentioned by rawr, check the contact pins. If the contacts are clean, there is nothing wrong with the camera. (There is no history of such pb with the K-7 at PF to the best of my knowledge,)

I am afraid that the lens has to back to CRK. HSM can be delicate, but there is not too much issues with Sigma lenses posted at PF, compared to SDM issues with DA*16-50mm, for example.
08-26-2013, 01:26 AM   #4
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,768
Original Poster
QuoteOriginally posted by rawr Quote
Sorry to hear of your hassles.
Never had a problem with mine, touch wood, whether at a rodeo or a gig, or on the K-x or the K-5.

Always make sure it is mounted properly and carefully, and the pins are clean on the mount though. Another Sigma lens of mine would sometimes give me problems when I didn't pay particular attention to those issues.
QuoteOriginally posted by hcc Quote
Sorry to hear your problems. As mentioned by rawr, check the contact pins. If the contacts are clean, there is nothing wrong with the camera. (There is no history of such pb with the K-7 at PF to the best of my knowledge,)

I am afraid that the lens has to back to CRK. HSM can be delicate, but there is not too much issues with Sigma lenses posted at PF, compared to SDM issues with DA*16-50mm, for example.
Thanks for your comments. I will clean the contacts again and if no improvement I will take the lens and camera back to CR Kennedy. Hopefully I can get to the bottom of this.

08-29-2013, 01:19 AM   #5
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,768
Original Poster
Good news.

The wonderful people at C R Kennedy swapped the defective lens for a brand new demonstration model they had in stock. (Mine was a surplus demo model in the first place) They are sending the old one back to Sigma with a suspected circuit board fault.

It is wonderful to deal with a company that stands by its products. Faulty devices do happen and that, while regrettable, I accept as a fact of life. The character of a brand and the supply chaiin is how they react when things do go wrong. In his regard I can find only the highest praise for CR Kennedy, the Australian distributor and their staff.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cr, failure, fault, hsm, k-mount, kennedy, lens, pentax lens, slr lens, week
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Focussing problem Sigma EX 70-200mm 1:2.8 II MACRO HSM Bruce Clark Troubleshooting and Beginner Help 2 06-18-2013 06:22 AM
Autofocus will not engage on K10 using Sigma 70-200mm f/2.8 II EX DG APO Macro HSM AF millesr Troubleshooting and Beginner Help 4 08-14-2012 11:18 PM
For Sale - Sold: Sigma 70-200mm f/2.8 EX DG Macro HSM II deadwolfbones Sold Items 8 02-02-2010 09:41 PM



All times are GMT -7. The time now is 10:39 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top