Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-29-2008, 11:46 PM   #1
Forum Member
budkid's Avatar

Join Date: Dec 2007
Location: California
Posts: 68
Trouble with used lens...

I bought a Sigma 28-105mm f2.8-4 on flebay. I took it out, and there were some problems. The "A" setting on the lens does not put the lens in "A" setting. While I am shooting photos, I could twist the aperture ring hard clockwise to make it go into "A" setting. But it does not stay. I could use the lens in manual mode with the use of the green button. On aperture mode, it will not shoot at the aperture selected on the lens. What should I do? Send it in? Any tips or things I should know?

03-30-2008, 06:01 AM   #2
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,345
QuoteOriginally posted by budkid Quote
I bought a Sigma 28-105mm f2.8-4 on flebay. I took it out, and there were some problems. The "A" setting on the lens does not put the lens in "A" setting. While I am shooting photos, I could twist the aperture ring hard clockwise to make it go into "A" setting. But it does not stay. I could use the lens in manual mode with the use of the green button. On aperture mode, it will not shoot at the aperture selected on the lens. What should I do? Send it in? Any tips or things I should know?
You might try cleaning the contacts on the lens mount, as they could be dirty.

To due this use a soft pencil eraser, not an abrasive one.

If that does not wirk, then I suspect the lens is defffective, or needs repair internally for the automatic apature switch.

You should retrun it in that case. If the lens can remain in A mode then the apature will work correctly
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, k-mount, lens, mode, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
still having trouble with this lens Deiberson Troubleshooting and Beginner Help 4 12-27-2009 02:44 PM
Trouble focusing with M lens garfield160 Pentax SLR Lens Discussion 13 06-22-2009 09:00 PM
So am I in trouble Eastern Shore Charlie Post Your Photos! 8 10-24-2008 08:46 AM
Help! Having trouble with lens lineup... maxwell1295 Pentax SLR Lens Discussion 11 04-24-2008 04:56 PM
trouble with focus fevbusch Photographic Technique 1 07-17-2007 11:05 AM



All times are GMT -7. The time now is 06:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top