Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-18-2014, 12:31 AM   #1
New Member




Join Date: Feb 2014
Location: Delaware
Posts: 15
Lens motor failure

How can I tell if the motor in my Pentax 300mm prime is malfunctioning? The accuracy of the auto focus system does not seem to be what it was and a couple of times recently I have had to "wake up" the lens before the auto focus system would work. I have had the lens for over a year now and it quickly became my favorite when I purchased it new. I use this lens ALOT for shooting birds and, though I also shoot with a K7 and 200D and now a K3, have had to send my K5 in for repair. The K5 had well over 105,000 shutter actuations.


Have I worn out the lens motor? When using all of my cameras and lenses, I replace my cameras' batteries as soon as the cameras indicate less than a full battery charge. This seems to keep the focusing quicker and more accurate. However, the problems I have been experiencing with the 300mm lens is not affected by replacing batteris.


If the lens should need the motor replaced, does anyone now what an estimate of the cost would be in US dollars?

02-18-2014, 01:09 AM   #2
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,180
If I recall correctly, you sometimes get an extended warranty when buying with certain credit cards. Try looking that up. Otherwise as far as I remember, the motor costs ~$250-350 to replace. But maybe they'll charge less, since this case shouts 'defect'.
02-18-2014, 05:31 AM   #3
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
I just recently had my DA* 50-135 repaired by CRIS. They replaced the SDM motor and the PCB, cleaned and adjusted the lens and return shipped it to me for $208.00. They didn't estimate it until they had the lens in thier shop. They also had to wait for parts from Pentax, but overall it took just a bit more than a month. I'm very happy with thier service. (they repaired an AF360FGZ for me previously).
YMMV.
02-18-2014, 05:59 AM   #4
Veteran Member
stormtech's Avatar

Join Date: Jan 2011
Location: In the boonies (NW Penna)
Photos: Gallery | Albums
Posts: 5,670
Sounds like the SDM is going out. Best thing to do is fill out the online form at the criscam site and send it in. They will evaluate the problem and give you a quote before performing any work. They are the authorized service center for Pentax.

https://www.criscam.com/

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
300mm, auto, cameras, focus, k5, lens, lens motor, motor, system
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Lens Copy Failure Rate? Driline Pentax SLR Lens Discussion 20 01-13-2014 07:22 AM
Pentax 18-135 lens motor durability DominicVII Troubleshooting and Beginner Help 14 12-04-2013 01:37 PM
k100 Super lens read failure mhanewich Troubleshooting and Beginner Help 3 07-26-2013 10:22 AM
Autofocus comparison : lens motor vs. body motor (screw drive) 6BQ5 Pentax K-30 & K-50 7 06-12-2013 12:12 PM
Symptoms of SDM failure on 50 - 135 lens BethC Pentax SLR Lens Discussion 33 05-15-2013 10:56 AM



All times are GMT -7. The time now is 06:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top