Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-15-2014, 04:30 PM   #1
Junior Member




Join Date: Nov 2013
Posts: 39
Vivitar P/K-A lens doesn't mount on K-30

Hi there,

I bought a vintage 80-200mm Vivitar zoom lens and I expected it mounts on my K-30 with no issue, but it doesn't!
After a bit of inspection I realized that Vivitar lens has a longer metal tip (i have no idea what it is called) compared to my vintage Pentax lenses.
See the attached photo. The left one is the Vivitar lens and the right one is an SMC Pentax 135mm lens.
How can I fix the issue? If I cut the tip does it solve the problem?

Attached Images
View Picture EXIF
PENTAX K-30  Photo 
05-15-2014, 04:58 PM   #2
Site Supporter




Join Date: Sep 2010
Posts: 456
Got it in one.
05-15-2014, 04:59 PM   #3
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
Yes, some old Vivs have that. Some people Dremel off the extra, but you can probably just remove the entire ring by removing the correct screws...
05-15-2014, 07:05 PM   #4
dms
Site Supporter




Join Date: Aug 2011
Location: New York, NY
Photos: Gallery
Posts: 1,556
Generally held on by 3 screws, remove them and then the shield and you should be fine. You can also at that point grind it down following one of your other lenses as a guide.

05-15-2014, 07:51 PM   #5
Junior Member




Join Date: Nov 2013
Posts: 39
Original Poster
So, if I can remove it and it's fine, what is the functionality of the part at all?
05-15-2014, 08:33 PM   #6
dms
Site Supporter




Join Date: Aug 2011
Location: New York, NY
Photos: Gallery
Posts: 1,556
I believe it is there to protect the aperture actuation lever from being bent--which can happen relatively easily--in which case the lens may not stop down to set aperture. It may also afford some additional protection from internal reflections (lens flare).
05-15-2014, 09:10 PM   #7
Junior Member




Join Date: Nov 2013
Posts: 39
Original Poster
Just two screws. Unscrewed and it's working perfectly now. Thank you all for your help.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
issue, k-30, k-mount, lens, pentax, pentax lens, slr lens, tip, vivitar, vivitar p/k-a lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using K Mount Manual Lens on K-30, K-50? Relativity Pentax K-30 & K-50 11 07-08-2014 04:05 PM
Sears 80-200mm PK-mount lens doesn't mount on K1000 kylemsguy Pentax SLR Lens Discussion 8 09-19-2013 11:44 AM
Vivitar p/k lens not mounting on K-5 weave2d2 Pentax SLR Lens Discussion 17 06-14-2013 07:55 AM
Lens doesn't mount on K-01 geirix Troubleshooting and Beginner Help 28 03-20-2013 05:53 PM
K Mount lens on K-30 TropicalMonkey Pentax K-30 & K-50 5 11-20-2012 07:30 AM



All times are GMT -7. The time now is 04:03 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top