Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-09-2008, 12:46 PM   #1
New Member
jpdsr3's Avatar

Join Date: Feb 2008
Location: Rhode Island USA
Photos: Gallery
Posts: 21
SMCP-FA 50mm f/1.4 over exposure

After hearing many praises of this lens I purchase one. When mounted on my K10D I have to correct for two stops of over exposure compaired to my DA lenses in the same light. Has anyone else had this problem? Pentax customer service said that this could be normal under some light conditions for a film lens being used on a digital camera. I wanted to send the lens in for service, but Pentax service didn't think it needed repair. If anyone has any input about this lens on a digital camera I would like to here from you.
Joe D.

05-09-2008, 12:57 PM   #2
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
Shot everything in M mode and see if the problem presists. If exposures are identical in M mode, then there is nothing to be adjusted.
05-10-2008, 07:56 AM   #3
New Member
jpdsr3's Avatar

Join Date: Feb 2008
Location: Rhode Island USA
Photos: Gallery
Posts: 21
Original Poster
Thanks for your advise, I have tried in manual mode with the same results. Of course I can correct for this, but was looking for a fix.
Joe D.
05-10-2008, 08:46 AM   #4
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
FWIW, my FA50/1.4 works swimmingly well on both my K10 and K20. I have learned that if the lens has an A setting, use it rather than the aperture ring.

05-10-2008, 03:10 PM   #5
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
QuoteOriginally posted by jpdsr3 Quote
Thanks for your advise, I have tried in manual mode with the same results. Of course I can correct for this, but was looking for a fix.
Joe D.
Since I am uncertain what the actual problem is from your description, you may try this. Set the camera in M mode and choose aperture f4 from the camera. Use DOF preview and look at the actual aperture blades stop down from the front of the lens. Now set the lens aperture ring to f4 and try again. Do both aperture blades stop down look identical? If so, then it is a metering issue only Pentax can address. If not, the aperture mechanism of the lens need to be adjusted (a rather simple job).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, exposure, k-mount, lens, light, pentax, pentax lens, service, slr lens, smcp-fa 50mm f/1.4
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax SMCP-A 50mm f/1.2; SMCP-FA 20-35mm f/4 Excellent + (CONUS) Wormtographer Sold Items 3 11-23-2010 08:55 AM
For Sale - Sold: K10D body, D-BG2 grip, D-BG4 grip, Pentax SMCP-FA 50mm f/1.4, Sigma DC 18-50mm cnote Sold Items 17 07-23-2010 02:40 PM
Pentax SMCP-FA 50mm f/1.4 Lens or Sigma 50mm f/1.4 EX DC HSM? NicK10D Pentax DSLR Discussion 7 06-23-2010 06:21 AM
For Sale - Sold: SMCP-M 50mm 1.4........SMCP-M 50mm 2.0........Helios-44 58mm 2.0 Tdo0003 Sold Items 3 06-09-2008 08:23 PM
For Sale - Sold: SMCP-A 135mm 2.8........SMCP-A 50mm 1.7 Tdo0003 Sold Items 0 06-08-2008 05:16 AM



All times are GMT -7. The time now is 05:53 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top