Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-19-2008, 04:14 PM   #1
Veteran Member
Tuner571's Avatar

Join Date: Mar 2008
Location: Ohio
Photos: Gallery | Albums
Posts: 1,550
Trouble with my Pentax A 50mm 1.7!

Was cleaning up my equipment today and I noticed for the first time that the aperture ring on my 50mm gets stuck at f/11 and it takes some jiggling to get it back to the A position which is what I use all the time. So I was wondering if this is the start of a serious problem here? The lens works wonders on my K100D Super and it would be a shame to lose one of my favorite lenses.

Here is a shot of it to show the condition it's in.



05-19-2008, 05:01 PM   #2
Site Supporter
Douglas_of_Sweden's Avatar

Join Date: Apr 2008
Location: Stockholm
Photos: Gallery
Posts: 3,353
I think this is a known problem, that the aperture rings are the weakest points on the A-lenses, my A50/1.7 has also the same tendency. For what its worth, it has not got worse since I first noticed it. I don't know what the actual cause is, and if there is something to do, besides sending it to Pentax. Anyone?
05-19-2008, 06:01 PM   #3
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
The A 50/1.7 has a poorly made plastic aperture ring. I don't have any issues with my other A lenses; they appear to be of M-lens build quality (16/2.8, 50/1.4, 50/2.8 macro, 85/1.4, 135/1.8, 200/4 Macro, 70-210).
05-20-2008, 07:33 AM   #4
JMS
Senior Member




Join Date: Oct 2007
Location: Wisconsin
Posts: 273
Same here. I have no problems with my other A- 28mm f2.8.

05-20-2008, 07:43 AM   #5
Veteran Member




Join Date: Mar 2008
Location: CT / NY
Photos: Gallery
Posts: 822
Am I missing something here? if you have the A model, wouldnt you just leave at "A" and control aperture in the camera?

I have three A lenses and I always leave them at the A setting. I know i am missing something here....
05-20-2008, 07:45 AM   #6
Senior Member




Join Date: Dec 2007
Location: Perth Australia
Photos: Gallery | Albums
Posts: 293
Like probably most people here, I haven't taken my a-50mm 2.0 off the A setting since the day I bought it. Thanks all for the warning.
05-20-2008, 11:07 AM   #7
Veteran Member
Tuner571's Avatar

Join Date: Mar 2008
Location: Ohio
Photos: Gallery | Albums
Posts: 1,550
Original Poster
QuoteOriginally posted by BBear Quote
Am I missing something here? if you have the A model, wouldnt you just leave at "A" and control aperture in the camera?

I have three A lenses and I always leave them at the A setting. I know i am missing something here....
Your right, I always have the lens on the A setting. However yesterday while cleaning my lenses I just happened to move it off the A setting and thats when I noticed the problem.
05-20-2008, 12:17 PM   #8
Site Supporter
Fl_Gulfer's Avatar

Join Date: Jul 2007
Location: Florida Gulfer
Photos: Albums
Posts: 3,052
No problems here with my SMC-A 50 1.7

05-20-2008, 12:23 PM   #9
Not Registered
Guest




I have had 2 A50 f1.7 and both had a similar problem. I dont think that it would get worst considering the few times that you will have to change the aperture ring.
05-20-2008, 01:05 PM   #10
Veteran Member
ftpaddict's Avatar

Join Date: Jan 2008
Location: Yurp
Photos: Gallery
Posts: 4,669
I'm fine with my A 50mm f/1.7
05-20-2008, 02:25 PM   #11
Senior Member
bentax's Avatar

Join Date: Jan 2008
Location: West Australia
Posts: 190
My A 50 1.7's ring turns fine as you'd like.
As far as can can tell you have to use the ring on my SuperA cos if you leave it on A you have no control.
05-20-2008, 04:56 PM   #12
JMS
Senior Member




Join Date: Oct 2007
Location: Wisconsin
Posts: 273
You have to use the ring on EVERY film SLR except the *ist.
05-21-2008, 03:01 AM   #13
Banned




Join Date: Oct 2007
Location: Savannah, U.S./Baguio City, P.H.
Posts: 5,979
no problems with my copy either.
05-21-2008, 03:03 AM   #14
Banned




Join Date: Oct 2007
Location: Savannah, U.S./Baguio City, P.H.
Posts: 5,979
QuoteOriginally posted by JMS Quote
You have to use the ring on EVERY film SLR except the *ist.

thats not entirely true. you don't have the same ease of use of say Av mode on older models but you don't have to use the aperture ring.
05-21-2008, 03:12 AM   #15
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
QuoteOriginally posted by Tuner571 Quote
Was cleaning up my equipment today and I noticed for the first time that the aperture ring on my 50mm gets stuck at f/11 and it takes some jiggling to get it back to the A position which is what I use all the time. So I was wondering if this is the start of a serious problem here? The lens works wonders on my K100D Super and it would be a shame to lose one of my favorite lenses.
Is it just the aperture ring that gets stuck? If it's left in A, does the actual aperture work smoothly?
Brian
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, k-mount, pentax a 50mm, pentax lens, slr lens, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DA 17-70mm having trouble focusing above 50mm dgaies Pentax SLR Lens Discussion 17 02-24-2012 04:05 PM
Trouble setting f stop on K7 with SMC FA 50mm 1.4 boy_and_wolf Pentax DSLR Discussion 2 11-29-2009 04:22 PM
Trouble with SMC F 50mm 1.7, request to F and FA owners tr13 Pentax SLR Lens Discussion 5 09-08-2009 11:53 PM
Is Pentax in trouble? I think so! jack56 Pentax News and Rumors 55 08-13-2009 12:42 AM
Is Pentax in trouble? jack56 Pentax News and Rumors 41 05-11-2009 02:53 PM



All times are GMT -7. The time now is 01:35 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top