Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2014, 01:40 AM   #16
Moderator
Site Supporter
Loyal Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 11,267
All's well that ends well.
Back. Up.

11-30-2014, 02:19 AM   #17
Veteran Member




Join Date: Nov 2014
Location: Edmonton
Posts: 600
Original Poster
Ha! Yeah you've got that right. I really just misinterpreted the role of the eeprom data. I thought it was a list of instructions that the body would present and the lens would recognize. Ie the body would suggest to the lens that it was in focus, not vice versa. But yes, lesson learned.

The tolerances must be VERY tight to have a random lens file work so well in a totally different lens.

I appreciate all the help guys. Cheers
11-30-2014, 05:03 AM   #18
Veteran Member
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 11,186
One other thing is that maybe the lens is busted in some way other than just SDM. Maybe it has other faults, as well. But I am glad you improved your situation
11-30-2014, 05:18 AM   #19
Veteran Member




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,182
Nice that you got the lens sorted. Good luck in the future

11-30-2014, 05:45 AM   #20
PEG Moderator
Loyal Site Supporter
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland... "Hold Infinity in the palm of your hand" - William Blake
Photos: Gallery
Posts: 57,804
QuoteOriginally posted by wibbly Quote
but I messed it up by loading the wrong lenseep file
I knew there must have been a reason why I stayed with manual lenses... but could nae think what it was.
01-09-2015, 04:16 PM   #21
Veteran Member




Join Date: Nov 2014
Location: Edmonton
Posts: 600
Original Poster
sorry to bump this again, but having used my 16-50 more than just for testing, it's still having focus issues.

if you are reading this and have your original lenseep file can you please email it to me?

wibbly(at)shaw.ca



thanks so much guys
01-12-2015, 12:55 AM   #22
Otis Memorial Pentaxian
Otis FanOtis FanOtis FanOtis FanOtis FanOtis Fan
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 16,397
If you receive one, you better hope that a unique lens ID is not expected as part of that file. You may need to do a side-by-side comparison in a text editor.

01-12-2015, 01:45 AM   #23
sTi
Forum Member




Join Date: Feb 2011
Posts: 98
QuoteOriginally posted by wibbly Quote
sorry to bump this again, but having used my 16-50 more than just for testing, it's still having focus issues.

if you are reading this and have your original lenseep file can you please email it to me?
The LensROM also contains focus calibration info; e.g. when you send in the 16-50 to get it calibrated, the new focus correction values are stored there.
You are in effect trying to use the focus calibration values of a different lens in your own copy. You may be able to find one that reasonably matches yours (you have to check at all focal lengths and distances to make sure), but then again you may not...
If it does not work out this way, I think Pentax service will be able to fix it.
01-12-2015, 07:17 AM   #24
Veteran Member




Join Date: Nov 2014
Location: Edmonton
Posts: 600
Original Poster
Yep, I'm well aware. I am just trying to exhaust all options before sending it in or just tossing it. I suspect Pentax service wouldn't fix it without replacing the SDM as well, so there is likely little point. Maybe I'll get lucky or maybe not. I guess well see
10-13-2015, 04:31 PM   #25
Senior Member




Join Date: Feb 2011
Location: UK
Posts: 103
The IT nerd in me got the best of me. As a test I backed up my lensROM and flashed a random copy from the database. I can't tell any difference in focus calibration at 16, 35, or 50mm regardless of the F-stop still requires the exact same +9/+10. The behavior seems identical. I may switch it back or just leave it this way for now, as it doesn't seem to make a bit of difference. I'd love to talk to a Pentax tech about how these things are calibrated at the factory service centers, how the programming is performed, etc.

I live close to Precision, I should figure out what bar those guys go to after work
10-13-2015, 09:19 PM   #26
bxf
Veteran Member
bxf's Avatar

Join Date: Jul 2010
Location: Lisbon area
Posts: 1,660
Does anyone have the EEPROM file for the FA 43 Limited? Mine (bought second hand) needs a +10 AF adjustment, and I don't know if a larger value would be better still. I wonder if another version of the EEPROM would be better.

Thanks.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, crop, f2.8, k-mount, pentax lens, pic, post, shots, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I need a DA 16-45 F4 for an upcoming holiday? p38arover Pentax SLR Lens Discussion 44 10-28-2014 03:25 PM
Machinery A Few From the Car Show B: Those Kids Think I'm An Idiot sherrvonne Post Your Photos! 2 05-06-2014 10:41 AM
Would you keep both an FA 50/1.4 and an M 50/1.7? ChooseAName Pentax SLR Lens Discussion 16 10-05-2012 03:52 AM
DA* 55mm f/1.4 - I'm an idiot, but oh well... DRabbit Pentax SLR Lens Discussion 18 05-12-2011 04:29 PM
I feel like an idiot! stormdore Photographic Technique 31 06-15-2008 06:53 PM



All times are GMT -7. The time now is 08:16 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top