Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-21-2008, 09:59 AM   #1
New Member




Join Date: Jun 2008
Location: BC
Posts: 6
trouble with focal length on m42 using K20

Hello
I am having trouble setting the focal length on my new Pentax k20. I bought the genuine Pentax M42 adapter and have tried my SMC 28 3.5, smc 35 3.5, SMC 50 1.4, SMC 105 2.8, SMC135 3.5 and my SMC200 4 (all M42 mount). When I put any of these lenses I am not prompted to set the focal length and I cannot change it in the menu as the "change focal length" is grey (not white like the rest of the menu items). When I put my K mount SMC A 50 1.7 lens on the camera prompts me to confirm the focal length of the lens. The focal length is to allow the image stabilization (IS) function to work. I can still take great pictures but, would like to have IS functioning with my favorite old lenses. I haven't read any where that the IS function is unavailable with the m42 lenses. Clarification on this would be appreciated.
thanking you in advance.

06-21-2008, 10:05 AM   #2
Veteran Member
KungPOW's Avatar

Join Date: Nov 2007
Location: Vancouver, Canada
Photos: Gallery
Posts: 1,702
have you tried setting the SR switch to "on" then turning the camera on? The prompt should be the first thing that appears on the back screen. That is the only way I know to set the focal length
06-21-2008, 10:18 AM   #3
New Member




Join Date: Jun 2008
Location: BC
Posts: 6
Original Poster
Thanks for the quick reply
Yes I have tried switching it on and off many times in combination with turning the camera on and off.
06-21-2008, 10:48 AM   #4
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
You have to set custom function 36 to "permitted" (Aperture ring use). If body does not allow aperture ring use, it will not know that you are using a non A type lens.

Once you set CF 36 to "permitted", when you attach any non A type lens, when you turn on camera it will prompt for focal lenght.


Hope this helps.

RB

06-21-2008, 10:54 AM   #5
New Member




Join Date: Jun 2008
Location: BC
Posts: 6
Original Poster
Thanks Rburgoss
Your solution worked. The strange thing is I thought I had done what you suggested before. I guess not. May the pentax gods shine upon you forever.
06-21-2008, 01:23 PM   #6
Veteran Member




Join Date: Mar 2008
Location: Nowhere, Sweden
Photos: Gallery
Posts: 654
QuoteOriginally posted by austina95 Quote
Thanks Rburgoss
Your solution worked. The strange thing is I thought I had done what you suggested before. I guess not. May the pentax gods shine upon you forever.
Can you try if focustrapping works on K20D? I know it did on K100D and that it does not on K10D without shorting the golden contact.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
function, k-mount, k20, length, lens, lenses, m42, menu, pentax lens, slr lens, smc, trouble
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 is 1.5 x focal length? rdrum76 Pentax DSLR Discussion 18 06-30-2009 08:30 AM
What is Focal Length Ole Photography Articles 2 05-15-2009 12:20 PM
setting manual lens focal length on K20 boyscout Troubleshooting and Beginner Help 9 05-01-2009 08:55 AM
Dialing in focal length on K20 gamgee Pentax SLR Lens Discussion 10 04-10-2008 03:29 PM
Focal Length ? deludel Photographic Technique 14 01-30-2008 06:58 PM



All times are GMT -7. The time now is 12:53 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top