Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-25-2008, 03:13 AM   #1
New Member




Join Date: Jun 2008
Location: Finland
Photos: Albums
Posts: 20
Clicking sound from the lens - loose parts?

Hi,

I recently got an Auto Revuenon 135/2.8 lens, which is in very good condition and works fine with my K200D, but off-camera it makes a clicking noise when turned in hand from side to side. When peering inside, it looks like there is some lever inside the lens moving loosely. The aperture and focus rings work just fine. I have not much experience with older lenses, so could someone tell me if this kind of clicking is normal or not.

The lens makes another kind of sound too, under/around the bayonet is a ring of ball bearings, and it looks like two or three balls are missing - due to the small gap the balls move freely and make a whirring sound when turned around.

Do you think I have a faulty lens, or do I worry for nothing?

Thanks,
Sami

06-25-2008, 06:20 AM   #2
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,135
QuoteOriginally posted by lockheed Quote
Hi,

I recently got an Auto Revuenon 135/2.8 lens, which is in very good condition and works fine with my K200D, but off-camera it makes a clicking noise when turned in hand from side to side. When peering inside, it looks like there is some lever inside the lens moving loosely. The aperture and focus rings work just fine. I have not much experience with older lenses, so could someone tell me if this kind of clicking is normal or not.

The lens makes another kind of sound too, under/around the bayonet is a ring of ball bearings, and it looks like two or three balls are missing - due to the small gap the balls move freely and make a whirring sound when turned around.

Do you think I have a faulty lens, or do I worry for nothing?

Thanks,
Sami
If it works, use it. A lot of the older inexpensive lenses (yours is one) made use of generous amounts of play in the mechanicals to keep them from jamming up. What you are describing sounds perfectly normal.
06-25-2008, 11:45 PM   #3
New Member




Join Date: Jun 2008
Location: Finland
Photos: Albums
Posts: 20
Original Poster
Ok, no problems then.
06-26-2008, 07:17 PM   #4
Veteran Member
TourDeForce's Avatar

Join Date: Jan 2008
Location: Florida
Photos: Gallery
Posts: 512
That reminds me. The Vivitar 135mm 2.8 is about due for retirement. Gotta hunt down a replacement some time in the next month or two.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
balls, k-mount, lens, pentax lens, slr lens, sound
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking Sound When Taking a Photo-K100D chuckdua Troubleshooting and Beginner Help 6 10-02-2010 10:37 PM
istDS not working, making clicking sound saharablue Pentax DSLR Discussion 6 09-07-2010 09:26 PM
loose parts in a K10d? yasha Troubleshooting and Beginner Help 4 05-23-2009 10:00 AM
Lens Grading Help and Shaking parts sound... greenboy Pentax SLR Lens Discussion 15 02-17-2009 06:54 AM
Clicking sound on my new 12-24 F4 DA kuau Pentax SLR Lens Discussion 6 01-05-2009 09:34 PM



All times are GMT -7. The time now is 05:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top