Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-18-2015, 01:54 PM   #1
Forum Member




Join Date: Aug 2014
Location: Munich
Posts: 75
Sigma 10-20 f3.5 HSM live view focusing problem

Hi everyone!
I've got a used copy of Sigma 10-20 f3.5 HSM lens on Ebay. Just after receiving the box, I've started to test it for proper operation on my K-5II. With the PDAF everything works fast and accurate even with a lack of light. Then I've switched to live view, and it doesn't even try to focus properly. Auto-focus goes back and forth couple of times (not fully, just within 20-30% of the focusing range) and never confirms. The same happens on my wife's K-01. Both cameras have the latest software. Have someone also experienced similar problems? I'm trying to understand, whether this is a known issue or my copy is damaged?
Thanks!

12-18-2015, 02:02 PM   #2
Pentaxian
bertwert's Avatar

Join Date: Jun 2015
Location: Golden, BC
Posts: 13,452
That's weird...
I thought liveview AF was more accurate and works better in low light - but is a lot slower.
Do both cameras live view AF fine with your other lenses?
12-18-2015, 02:06 PM - 1 Like   #3
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,301
Make sure the lens contacts are clean. But really, it's the camera that performs the CDAF.
12-18-2015, 02:56 PM - 1 Like   #4
Site Supporter
Site Supporter




Join Date: Aug 2010
Posts: 512
Some Sigma HSM lenses can have issues with CDAF. For example, the 8-16 had to have a firmware update to work properly with the Nikon d5300 in Live View. If you search you'll find some threads on the subject. Luckily the 10-20 is easy to set to hyperfocal (if that's what you want).

12-18-2015, 03:34 PM   #5
Veteran Member




Join Date: Aug 2014
Posts: 407
I figured it was fixed by the newer lenses, but as krazykat said, there are issues with Sigma and CDAF. My 70-200 HSM II just bounces back and forth on live view and won't lock focus at all on my k3. Sigma said I could send it in for a firmware flash because the issue has been fixed, but that's a sports and headshot lens for me that I never use for tripod work anyway, so no need.

Since your 10-20 would likely be exclusively landscape, I see where cdaf would be useful. Call Sigma. Best I recall, you only have to pay shipping both ways for the fix.
12-18-2015, 04:00 PM   #6
Senior Member
fb_penpho's Avatar

Join Date: Jul 2009
Location: London
Photos: Gallery
Posts: 212
Get a firmware update if one is available or only use manual focus in liveview with it.
12-18-2015, 07:04 PM   #7
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,301
Don't you need the SIGMA USB Dock to update firmware?
12-18-2015, 09:29 PM   #8
Pentaxian
kiwi_jono's Avatar

Join Date: Dec 2009
Location: Christchurch, New Zealand
Photos: Gallery | Albums
Posts: 2,002
Interesting. My 10-20 f3.5 focusses Ok in Liveview.
However the Tamron 70-200 f2.8 is known for having focus problems in liveview (mine does).

12-19-2015, 04:55 AM   #9
ars
Forum Member




Join Date: Aug 2014
Location: Munich
Posts: 75
Original Poster
Thanks to everyone for the replies! Checked today again in the daylight - the same story on both cameras - flounce back and forth within a small range, no lock. PDAF focuses accurately.... I experienced no problems with any of my lenses in the live view before (except of sigma 100-300 when used with sigma 1.4x converter). Will contact Sigma after the Christmas holidays!
12-19-2015, 05:05 AM   #10
bxf
Pentaxian
bxf's Avatar

Join Date: Jul 2010
Location: Lisbon area
Posts: 1,567
QuoteOriginally posted by fb_penpho Quote
Get a firmware update if one is available or only use manual focus in liveview with it.
What he said. This should be done free of charge by the SIgma distributor in your area.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
10-20, auto-focus, copy, f3.5, f3.5 hsm, focusing, hsm, hsm live view, k-5ii, k-mount, pentax lens, problem, sigma, sigma 10-20 f3.5, slr lens, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Sigma (PentaxMount) 10-20 f3.5 EX DC HSM crisi2000 Sold Items 5 06-03-2015 04:24 AM
For Sale - Sold: Sigma 10-20mm F3.5 EX DC HSM for Pentax 10-20 3.5 (PRICE REDUCED) transam879 Sold Items 11 12-02-2014 03:07 PM
For Sale - Sold: Sigma 10-20 F3.5 EX DC HSM Chris009 Sold Items 12 08-15-2014 05:22 PM
For Sale - Sold: Sigma 10-20 f3.5 EX DC HSM Munki Sold Items 2 11-24-2012 07:27 AM
aha sigma 10-20 f3.5 HSM issue parsons Pentax SLR Lens Discussion 15 04-17-2010 04:00 AM



All times are GMT -7. The time now is 03:44 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top