Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-25-2016, 10:02 AM   #16
Senior Member
Bonobo's Avatar

Join Date: Feb 2010
Location: St. Louis
Photos: Albums
Posts: 226
Trying to do this on a K3, firmware v 1.21, and I am stuck on step 4. Any idea why it might not transfer the original Lenseep file to my SD?

10-26-2016, 10:09 AM   #17
Site Supporter
Site Supporter




Join Date: Mar 2011
Location: Alexandria, VA
Photos: Gallery | Albums
Posts: 155
QuoteOriginally posted by Bonobo Quote
Trying to do this on a K3, firmware v 1.21, and I am stuck on step 4. Any idea why it might not transfer the original Lenseep file to my SD?
Quick search showed that others have also had this problem trying to use a K3 - see here: https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/328557-n...crewdrive.html From my experience, I know that a K5IIs definitely works. Seems that other prior models also do, so maybe it's from K3 forwards that issues arise.
10-27-2016, 06:53 AM   #18
Senior Member
Bonobo's Avatar

Join Date: Feb 2010
Location: St. Louis
Photos: Albums
Posts: 226
Damn. I'd known that was the case in the past but I thought this workaround was newer and potentially a cure as a result of some diligent code work or a new firmware edition. I wouldn't put anything past the users we've got on here.

Thankfully none of my lenses are dead (yet), I just wanted to see how they performed w/out SDM.
11-11-2016, 01:21 PM   #19
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery
Posts: 829
Curious whether anyone has ever successfully converted the DA* 55 to screwdrive? I used it this past weekend for a few portraits and don't typically use autofocus for those anyway. But was downstairs and decide to take a quick shot of something in the kitchen and used (or tried to use) autofocus. No go, no response. It might have been just a blip and I'll be looking at it again this weekend. but curious if the SDM has actually failed if screwdrive is an option.

12-01-2016, 04:45 AM   #20
New Member




Join Date: Apr 2016
Posts: 2
@gatorguy Pentax DA*55 can't be converted from SDM to screwdrive. It doesn't have screwdrive motor.
12-02-2016, 01:06 PM   #21
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery
Posts: 829
QuoteOriginally posted by playerone Quote
@gatorguy Pentax DA*55 can't be converted from SDM to screwdrive. It doesn't have screwdrive motor.
Thanks @Playerone. Guess it's manual then, tho I'll take a close look at the pins to see if I see anything obvious.
12-06-2016, 02:44 PM   #22
Forum Member
gzub's Avatar

Join Date: Jan 2014
Location: Bydgoszcz
Photos: Gallery
Posts: 98
Do you think it can work when my sdm is already dead and stucked in the lens. I own 17-70. Like this lens but auto focus always was a problem. I paid for new motor drive but it need replacement again and won't put more money into it.
12-09-2016, 05:41 AM   #23
Veteran Member
Blacknight659's Avatar

Join Date: Aug 2013
Photos: Gallery | Albums
Posts: 731
Original Poster
QuoteOriginally posted by gzub Quote
Do you think it can work when my sdm is already dead and stucked in the lens. I own 17-70. Like this lens but auto focus always was a problem. I paid for new motor drive but it need replacement again and won't put more money into it.
I don't know if it will work on the 17-70. I had my SDM jam on my 50-135 before I converted. I attached the lens to my film AF body and the screw drive was activated and freeded up the jam. Maybe you could try to spin the focus screw on the lens mount if the lens has one.

IDK if the lens can be converted to screw drive. I wish all the best to you. I hope they replace this lens with a DC motor version.

12-09-2016, 05:45 AM   #24
Forum Member
gzub's Avatar

Join Date: Jan 2014
Location: Bydgoszcz
Photos: Gallery
Posts: 98
I will give it a try . Don't really have a choice and nothing too loose.
12-11-2016, 11:35 AM   #25
New Member




Join Date: Dec 2010
Location: Toronto
Posts: 4
My 50-135 needed to be woken up every time I used it. As the SDM drive had already been for repair twice at Siemens Canada (before they closed their repair shop...) I tried this conversion: Did it with my old K5, worked fine, lens works now also fine on my K3II -> thanks for the detailed video and step-by-step description!
12-11-2016, 11:58 AM   #26
Veteran Member
Blacknight659's Avatar

Join Date: Aug 2013
Photos: Gallery | Albums
Posts: 731
Original Poster
QuoteOriginally posted by TeaTree Quote
My 50-135 needed to be woken up every time I used it. As the SDM drive had already been for repair twice at Siemens Canada (before they closed their repair shop...) I tried this conversion: Did it with my old K5, worked fine, lens works now also fine on my K3II -> thanks for the detailed video and step-by-step description!
Not a problem, I am glad I could help. I feel Ricoh should speak to this issue. Too many of us have this problem. I am happy there is an answer for those willing to hack their lens. Too bad the 60-250 and 55 can't be converted.
01-08-2017, 07:35 AM   #27
Site Supporter
Site Supporter
fwwidall's Avatar

Join Date: Sep 2014
Location: Waterloo, Ontario
Photos: Gallery | Albums
Posts: 160
A big "thank you" from me for this great posting. My six year old DA*200's SDM failed this weekend, and I was easily able to convert it to screw drive with these instructions using my K5. The SDM had failed once before about a year after I purchased the lens and it was repaired under warranty at that time. Hopefully I can now get at least another six years of great images form this lens. Thanks again, Fred.
01-08-2017, 08:19 AM   #28
Forum Member
DavidDwight's Avatar

Join Date: May 2014
Location: Indianapolis
Photos: Gallery | Albums
Posts: 60
To anyone who has done this conversion: I've recently noticed some anomalies with two lenses I did this to and not sure if it is coincidental or cause. I have not gone back and changed it lens firmware back to the original file (which I saved) to see if the anomalies disappear (which would confirm it for me - thought I would ask before going to the effort). The anomalies? 1) camera not saving the fine focus adjustment calibration. I the the lens off, put another on and then switch back and it goes back to "none set" as if it doesn't recognize the lens. 2) the EXIF lens information is gone - going back a long way in my library it was clearly there but recently it is gone (but there for other lenses).

So could this change change how the camera recognizes the lens? It does not seem like a logical way to design the system but ...
01-08-2017, 08:44 AM   #29
Site Supporter
Site Supporter
fwwidall's Avatar

Join Date: Sep 2014
Location: Waterloo, Ontario
Photos: Gallery | Albums
Posts: 160
I just tested my newly converted DA*200 on my K3, and I can't replicate your issues.

1) The fine focus adjustment calibration is being saved correctly, as far as I can see. I set it to '+10', changed to another lens which showed up as '+7', then switched back to the DA*200 which again showed up as '+10'

2) I ran a couple of images through 'exiftool' and the EXIF data appears normal, including the LensID.

Fred.
01-08-2017, 03:08 PM   #30
Veteran Member
Blacknight659's Avatar

Join Date: Aug 2013
Photos: Gallery | Albums
Posts: 731
Original Poster
QuoteOriginally posted by fwwidall Quote
A big "thank you" from me for this great posting. My six year old DA*200's SDM failed this weekend, and I was easily able to convert it to screw drive with these instructions using my K5. The SDM had failed once before about a year after I purchased the lens and it was repaired under warranty at that time. Hopefully I can now get at least another six years of great images form this lens. Thanks again, Fred.
You are very welcome! I am happy this has helped so many people. Thanks for letting us know!

---------- Post added 01-08-17 at 04:13 PM ----------

QuoteOriginally posted by DavidDwight Quote
To anyone who has done this conversion: I've recently noticed some anomalies with two lenses I did this to and not sure if it is coincidental or cause. I have not gone back and changed it lens firmware back to the original file (which I saved) to see if the anomalies disappear (which would confirm it for me - thought I would ask before going to the effort). The anomalies? 1) camera not saving the fine focus adjustment calibration. I the the lens off, put another on and then switch back and it goes back to "none set" as if it doesn't recognize the lens. 2) the EXIF lens information is gone - going back a long way in my library it was clearly there but recently it is gone (but there for other lenses).

So could this change change how the camera recognizes the lens? It does not seem like a logical way to design the system but ...
I can't say I have these issues. It is my understanding we are only adjusting the lens rom that acknowledges the SDM motor is ready for use. I believe when this "check" happens, our adjustments bypass the "motor is present" or the check fails and by default, screw drive is used. I hate to point to the camera for these issues, but there could be an issue there OR perhaps there is additional issues with your lens other than the SDM and Rom mod.

I hate to hear you are having these issues. Please let us know the outcome.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
anomalies, camera, card, change, drive, file, files, firmware, hack, issues, k-mount, lens, mode, pentax, pentax lens, pktether, pm, post, power, profile, rom, screw, sd, sdm, slr lens, thanks, thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: SDM to Screwdrive Conversions UncleVanya Photographic Equipment for Sale 216 01-31-2019 04:08 PM
For Sale - Sold: SMC Pentax-DA* 16-50mm F2.8 ED AL [IF] SDM converted to screwdrive transam879 Sold Items 4 04-08-2015 09:22 AM
SDM failure in body without default to screwdrive? kxr4trids Pentax DSLR Discussion 8 08-14-2010 06:41 AM
K20D defaulting to screwdrive focus instead of SDM shemj Pentax DSLR Discussion 15 01-26-2010 04:22 PM
[Wanted] tutorial to convert/edit video from K-7 to netuser Video and Pentax HDSLRs 5 09-14-2009 04:01 PM



All times are GMT -7. The time now is 07:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top