Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-05-2016, 09:05 AM   #1
Pentaxian
seacapt's Avatar

Join Date: Nov 2008
Location: North Carolina , USA
Photos: Gallery
Posts: 2,263
Tamron SP 80-200 f2.8 Not openning past f4

This has been and is one of my mainstay lenses. Was horrified when I realized it wasn't openning. Changed adaptors and cameras with no difference. Any suggestions or info on who will work on adaptalls? Anybody have one that they want to sell at a reasonable price?

09-05-2016, 12:05 PM   #2
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 1,709
I had a similar problem wth an 01B 24mm. Turned out the connection - a small wheel - under the adaptall mount was slightly bent out of place. A judicious straightening fixed things.

This is the relevant post from the adaptall club thread.

https://www.pentaxforums.com/forums/122-lens-clubs/59769-adaptall-mount-club-...ml#post2696644

Last edited by marcusBMG; 09-05-2016 at 01:03 PM.
09-05-2016, 05:56 PM   #3
Pentaxian
seacapt's Avatar

Join Date: Nov 2008
Location: North Carolina , USA
Photos: Gallery
Posts: 2,263
Original Poster
Thanks for that , it sounds plausible. If I manually turn the app. ring it opens but the camera will not open it all the way with the "A" function.
09-06-2016, 03:22 AM   #4
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 1,709
Ah well in that case it's probably not that connection, because that would affect all usage.
When you say "it won't go past f4", do you mean that the f number display won't go past f4 ie down to f2.8? If so, this is a known glitch with some PKA mounts. Check out these pages by Steen Brun (stone G here on PF).

Tamron Adaptall-2 Custom Mount for Pentax A

09-09-2016, 07:52 PM   #5
Pentaxian
seacapt's Avatar

Join Date: Nov 2008
Location: North Carolina , USA
Photos: Gallery
Posts: 2,263
Original Poster
Been working too much for a few days , sorry so long to reply.
Marcus thanks for the suggestion but I did swap adaptors with another fast SP lens - no difference so I think the problem is in the lens. Would love to find an old experienced tech who would be willing to work on it.
09-10-2016, 06:03 AM   #6
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 1,709
Suggest you PM dcshooter (Brian)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, pentax lens, slr lens, sp 80-200 f2.8, tamron sp
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old vs New on K-1 Tamron 80-200 F2.8 vs/ Tamron 70-200 F2.8 (plus SMCP F35-105 added) Erictator Pentax K-1 10 06-18-2016 12:19 PM
Tamron SP 80-200 f2.8 adaptall2 Pimps Pentax SLR Lens Discussion 6 10-29-2010 11:35 AM
tamron sp 80*200/2.8 Djteddy Pentax SLR Lens Discussion 8 10-31-2008 11:41 AM
For Sale - Sold: FS: Tamron 80-200 f2.8 SP & KA mount K10Perry Sold Items 7 02-06-2008 03:59 PM



All times are GMT -7. The time now is 01:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top