Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-15-2016, 03:44 AM   #1
Junior Member




Join Date: Oct 2016
Photos: Gallery
Posts: 28
55mm f1.2 Manual focus lens doesn't work on K1? Question...

I have a 55mm f1.2 Porst lens on the Pentax K1 and can't get the aperture to work and perhaps it's just a simple menu fix?

The lens is old and doesn't communicate with the body. And that's fine. I can deal with the F - - for the aperture and manual metering.

But the aperture ring doesn't work. Ah ha! Time to use the green button for stop down metering as works on my friend's manual lens. No luck on the 55mm nor does the aperture change when you shoot.

What am I missing? Are my only options to shoot everything wide open or to file off the catch on the lens that keeps the aperture open when it's attached to the camera?

Thanks!

Ben

10-15-2016, 05:12 AM   #2
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 11,183
Stuck aperture is often a problem with that lens, according to reports. Feel free to search some threads about this, or read here: Porst 55mm F1.2 Color Reflex MC Auto Lens Reviews - Miscellaneous Lenses - Pentax Lens Review Database

Since it has no A mode on aperture ring, you cannot select aperture from camera anyway, and it will always say F---. Nevertheless, you should go to Menu of camera and near the back Enable the Aperture ring use. But this, or even green button metering, will not fix a mechanical lens problem
10-15-2016, 05:33 AM   #3
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 18,068
A few lenses have painted mounts that stop electrical contact with the body. I can't recall the exact symptom but I know a fix is to apply a small bit of foil on a spot on the mount - can anyone clarify if that could apply here?
10-15-2016, 05:38 AM   #4
Pentaxian
D1N0's Avatar

Join Date: May 2012
Location: ---
Photos: Gallery
Posts: 6,330
Check this topic: https://www.pentaxforums.com/forums/54-pentax-lens-articles/110657-how-use-me...-k-30-etc.html

If it doesn't work either the contacts aren't shorted out (use a piece of tin foil) or you have sticky aperture blades (clean them). by the way the only reason to have a F1.2 lens is to shoot it wide open. You can do that in any mode.

10-15-2016, 07:04 AM   #5
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 2,363
QuoteOriginally posted by UncleVanya Quote
apply a small bit of foil on a spot on the mount - can anyone clarify if that could apply here?
More on this here:

https://www.pentaxforums.com/forums/116-pentax-k-r/271872-tests-plated-vs-pai...r-whats-t.html
10-15-2016, 08:13 AM   #6
Junior Member
Ken Pimontel's Avatar

Join Date: Dec 2015
Posts: 42
QuoteOriginally posted by UncleVanya Quote
A few lenses have painted mounts that stop electrical contact with the body. I can't recall the exact symptom but I know a fix is to apply a small bit of foil on a spot on the mount - can anyone clarify if that could apply here?
Yes. The Porst does not short the contact. Add foil.
10-15-2016, 05:36 PM   #7
Junior Member




Join Date: Oct 2016
Photos: Gallery
Posts: 28
Original Poster
Excellent thanks! It was the black anodising coating on the lens ring. I filed it off and it works fine now. Lovely lens, totally different character at f4 and beyond so a nice versatile beast.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
55mm, 55mm f1.2, aperture, f1.2, f1.2 manual focus, focus lens, k-mount, k1, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
manual focus lens on K1 micl161 Troubleshooting and Beginner Help 2 08-25-2016 07:00 AM
manual mode and the 01 lens. f1.9 setting doesn't stick? hoffo Pentax Q 6 07-07-2016 09:02 PM
*istD - focus blink doesn't work for one lens YQG Troubleshooting and Beginner Help 6 08-11-2014 08:12 PM
Manual Focus why doesn't AF button work rsoph Pentax K-5 6 12-18-2011 05:27 AM



All times are GMT -7. The time now is 11:32 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top