Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2017, 05:46 PM   #1
Forum Member




Join Date: Nov 2016
Location: Edinburgh
Posts: 76
Pentax 15-30 - AF Issue

Folks,

Has anyone had previous issues with the AF motor on the 15-30? I've been using mine only with manual focus of late as I've been doing long exposures through a 10 stop filter which prevents reliable autofocus.
I've just put the lens back on the K1 today and flicked it to Autofocus, I got a loud noise almost like an old screw drive lens whens its hunting through the focus scale and then it stopped and won't focus now at all, other lenses seem ok on the body so I think I can rule out the K1 being the issue.

Its even more a pain as I'd arranged to sell the lens so I've had to cancel the sale.

I know a few folks previously on Nikon have had issues with the Tamron variant of the lens so I suppose it could be the same in the Pentax? At least its under warranty but its still a pain, wasn't expecting issues with such an expensive lens.

03-17-2017, 07:45 PM   #2
Veteran Member
Driline's Avatar

Join Date: Dec 2012
Location: IOWA Where the Tall Corn Grows
Photos: Gallery
Posts: 2,988
Ahh....another rank and file member of the customer lens quality control department. You should feel honored
03-18-2017, 03:44 AM   #3
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 2,758
Mine has behaved impeccably.
03-18-2017, 05:58 AM   #4
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 467
I am sure you have tried all of the easy fix solutions like cleaning the camera and lens contacts? From the sounds of things, it does seem likely to be the motor. How long were you using it manual only? How long have you had the lens and is it still under warranty? If so, should be good outcome. I often use mine manual only for astrophotography (of course without the neutral density filters) and have had good luck so far. I have only had my Pentax 15-30 for 9 months.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, autofocus, focus, issue, issues, k-mount, k1, lens, pain, pentax, pentax 15-30 af, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lee Filters SW150 - Tamron 15-30mm adapter fits Pentax 15-30mm variant qdfb Pentax SLR Lens Discussion 5 07-16-2016 12:45 PM
PENTAX Q7 + 5-15 + 15-45 = A$699 CRK webstore raider Pentax Q 3 10-27-2013 09:58 PM
AF issue with 15 Limited on K5 KerryMcClain Troubleshooting and Beginner Help 3 06-04-2011 09:01 AM



All times are GMT -7. The time now is 05:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top