Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-17-2008, 11:23 AM   #1
New Member
davieFL's Avatar

Join Date: Jun 2008
Location: South Florida
Posts: 7
SMC DA*50-135 gone bad

I have a SMC DA*50-135 lens for 2 months and all of the sudden, the autofocus, which is usually extremely quiet (or shall I say totally quiet), started making a squeaky noise during focusing.

Minutes later the autofocus sound began sounding even louder, like a cheaper zoom lens. Also the camera is really struggling to focus.

The camera works ok with other lenses so I am pretty sure it's the lens, not the body.

Saddly, I am going to Peru (including machu picchu) in 2 weeks...and probably without that lens.

What should I expect from Pentax warranty support (I live in Florida)?

Any experiences to share?

08-17-2008, 02:49 PM   #2
Senior Member




Join Date: Jan 2008
Location: Barrie, ON
Photos: Gallery
Posts: 174
some WD-40 will fix that right up!!! I have no idea. My lens took like 4-5 weeks to get back in my hands from Pentax Canada. Good luck though!

Here is my experience with Pentax Canada. My 50mm would not focus to infinity, so I took it in to Henry's (a Canadian retail store) and they sent it away. After the 5 weeks I got it back. I took it out of the box and I looked at the lenses, and on both sides there were little scratches like it was put it in a vise. So now Pentax has it again because on top of the scratches, it would still not focus to infinity. So I hope that Pentax USA is a little better for you!

Last edited by ghost; 08-17-2008 at 02:55 PM.
08-17-2008, 04:12 PM   #3
Veteran Member
borno's Avatar

Join Date: Nov 2006
Location: md-usa
Photos: Gallery | Albums
Posts: 2,580
I think a firmware function to switch to screwdrive if the focus motor failed would be nice. Then we could use regular teleconverters. Hope you get it back in time for your trip
08-17-2008, 04:23 PM   #4
Site Supporter
Site Supporter
Fl_Gulfer's Avatar

Join Date: Jul 2007
Location: Florida Gulfer
Photos: Albums
Posts: 3,052
I would call them and explain the situation. Maybe if you gave a credit card number and sent yours in they would send you one to use on your trip.

08-17-2008, 04:55 PM   #5
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
I think this is the first time I've heard of a 50 - 135 going bad Davie,
I hope that you get it back on time for your trip. And have fun on it.

QuoteOriginally posted by ghost Quote
some WD-40 will fix that right up!!! I have no idea. My lens took like 4-5 weeks to get back in my hands from Pentax Canada. Good luck though!

Here is my experience with Pentax Canada. My 50mm would not focus to infinity, so I took it in to Henry's (a Canadian retail store) and they sent it away. After the 5 weeks I got it back. I took it out of the box and I looked at the lenses, and on both sides there were little scratches like it was put it in a vise. So now Pentax has it again because on top of the scratches, it would still not focus to infinity. So I hope that Pentax USA is a little better for you!
Sorry to hear about that Ghost.

Pentax USA is 1000x better than Pentax Canada
I've seen the Canadian division say an obviously faulty camera proved to be good. It would freeze up every few minutes.
08-17-2008, 06:33 PM   #6
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
I don't want to hijack this thread but I also had AWEFULL service from Pentax Canada...
09-29-2008, 07:58 PM   #7
Senior Member




Join Date: Dec 2007
Location: Louisiana
Posts: 226
What was the outcome of your lens? I just bought one from a member here and I tried it out when it arrived this afternoon and it is squeaking like crazy. It seems to be a little slow on the focusing as well. I hope I did not just get takin for a ride

Last edited by cajuncutter; 09-29-2008 at 08:36 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, da*50-135, k-mount, lens, pentax lens, slr lens, smc
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinon 135 & Chinar 135 , Good Bad or Ugly seacapt Pentax SLR Lens Discussion 1 02-26-2010 09:03 PM
Is my 50-135 F2.8 a bad copy, With photo samples m42geo Pentax SLR Lens Discussion 39 06-19-2009 01:49 PM
DA 50-135. Have I got a bad one? Lloydy Pentax SLR Lens Discussion 17 04-25-2009 06:47 PM
Brand new DA* 50-135....bad cputeq Pentax SLR Lens Discussion 4 07-03-2008 11:05 AM
Not a bad price. 50-135 f2.6 magnum1 Pentax SLR Lens Discussion 17 12-10-2007 07:05 PM



All times are GMT -7. The time now is 08:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top