Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-25-2019, 01:01 PM   #1
Site Supporter
Site Supporter




Join Date: Nov 2016
Photos: Gallery
Posts: 308
Tamron 17-50 does not autofocus on Kx. Please help.

I recently sold my Tamron 17-50 f2.8 due to lack of use. Today the buyer received the lens, but he claims that it does not autofocus at all on his Kx (manual focus still works, and his kit 18-55 also autofocuses fine).This is something quite surprising for me, as I never experienced that before. Though it usage has been reducing and reducing along the time, I can't recall any instance where there was an issue with its autofocus, and shortly before selling the lens, I also used it for a test, and there was no problem.

Granted, I have a KP and a K30, which are more advanced than the Kx. I also have a faulty Kx that I can't really use, so I can't tell whether the lens worked with the Kx before, but in my opinion there should not be a problem or special setting needed.

I already asked the buyer to recheck whether he mounted the lens correctly, but other than that does any of you have an idea of what could be the reason? Firmware maybe? Can the autofocus motor break during transportation?

Thank you.

07-25-2019, 01:12 PM - 2 Likes   #2
Loyal Site Supporter
Loyal Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 1,971
Hello,

Start with the basics: Ask the buyer to carefully clean the contacts of both the lens and the camera and to make sure no contacts are sunken in. Also, make sure the lens is not locked by the little switch. Of course make sure the camera is set to AF and not MF.

By the way, the autofocus motor is in the camera. This is a screwdrive AF lens.
Thanks,
07-25-2019, 02:53 PM - 1 Like   #3
Forum Member
Joe Dusel's Avatar

Join Date: Aug 2014
Location: Vista, CA
Posts: 86
Could be that one of the contacts on the lens got bent. If that happens it won't autofocus for sure. That happened to me one night while changing lenses in a dark venue. Fortunately I was able to bend the contact back into place and it works fine.
07-25-2019, 03:23 PM - 3 Likes   #4
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 39,130
QuoteOriginally posted by ismaelg Quote
By the way, the autofocus motor is in the camera. This is a screwdrive AF lens.
...and should not require other than the KAF contacts on the mount face.

Questions to ask the buyer:
  • Does the viewfinder display and rear LCD indicate MF or AF when lens is mounted and the body AF switch set to AF
  • If the answer is "M" or "MF" to the above, the next question is whether the "F--" displays instead of an aperture value in the viewfinder and rear LCD display
  • If "M" and "F--", the "A" contact on the mount is not being detected
  • If "M" only, the "data" pin is not being detected
Both failures to detect may be due gunge on the contacts, subtle misalignment, or physical damage to mount or lens internals (assuming the camera side is good). Whether such occurred before of after the lens left your hands is another matter.


Steve


Last edited by stevebrot; 07-25-2019 at 03:32 PM.
08-06-2019, 05:12 AM   #5
Bui
Site Supporter
Site Supporter




Join Date: Nov 2016
Photos: Gallery
Posts: 308
Original Poster
QuoteOriginally posted by stevebrot Quote
...and should not require other than the KAF contacts on the mount face.

Questions to ask the buyer:
  • Does the viewfinder display and rear LCD indicate MF or AF when lens is mounted and the body AF switch set to AF
  • If the answer is "M" or "MF" to the above, the next question is whether the "F--" displays instead of an aperture value in the viewfinder and rear LCD display
  • If "M" and "F--", the "A" contact on the mount is not being detected
  • If "M" only, the "data" pin is not being detected
Both failures to detect may be due gunge on the contacts, subtle misalignment, or physical damage to mount or lens internals (assuming the camera side is good). Whether such occurred before of after the lens left your hands is another matter.


Steve
So the buyer said he did so and he only saw MF displayed, so I guess it's a contact issue. He also said be brought both the lens, his Kx, and his kit lens too, to a technician, and the technician said the Tamron was broken. So I refunded him and asked him to send me back the lens.

Now is the best part: I received the lens back yesterday. I immediately put in on my KP to test. AF worked flawlessly. Put it on the K30. Worked again. Went to another person's place, borrowed his Kx for 5 minutes. Worked again. So I lost money for the shipping back, plus the delay and everything, but very happy to see the lens still functioning well.

I guess it's a specific-lens-does-not-like-a-specific-camera problem? Because otherwise what could explain the issue?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, buyer, k-mount, kx, lens, pentax lens, slr lens, tamron
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
PLEASE HELP! K-50 Does not shoot with flash and says "battery depleted" KevinMoss Pentax K-30 & K-50 6 09-17-2017 07:34 AM
Help me decide: Tamron 17-50, Pentax DA 16-45, or Sigma 17-50 for my K-01 yellowbrick Pentax SLR Lens Discussion 38 04-30-2016 07:26 AM
For Sale - Sold: Pentax K-m + 50-135 + F 100 macro + sigma 17-70 + 50-150 + tamron 17-50 + metz 50 AF blem49 Sold Items 11 07-26-2013 03:25 PM
For Sale - Sold: K-5, 16-50,50-135,65-250, Sigma 17-50, 50 1.4, 50 1.8, Tamron 90 2.8, Flashes virarfast Sold Items 8 04-04-2013 02:30 PM
Debating between Sigma 17-50 mm, Tamron 17-50mm, Tamron 28-75mm, Tokina 16-50 babaloohead Pentax SLR Lens Discussion 25 03-23-2013 08:56 AM



All times are GMT -7. The time now is 12:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top