Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-06-2019, 02:34 PM   #1
New Member




Join Date: Jul 2019
Posts: 4
Pentax FA 50 f1.4 autofocus?

Hi all

Apologies if this is an absurd question as Iím a bit of a noob to Pentax.

Iíve gone a little lens wild and bought via eBay an FA 50mm f1.4 and noticed in the reviews here that itís autofocus through a screw...

I have a Pentax KP and have no idea how to get my lens to autofocus. Iíve switched on the AF and nothing. On the camera the F value is flashing as it canít pick it up from the dial.

Am I trying to get it to do something it canít?

Thank you in anticipation!!

Tim

08-06-2019, 02:39 PM - 1 Like   #2
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 16,042
Hello and welcome to the forums

It sounds as if the camera isn't communicating properly with the lens. Assuming your other AF lenses are working fine with the camera, clean the lens' electrical contacts and the mount ring, then re-mount the lens and try again.

Let us know how you get on?
08-06-2019, 02:43 PM - 1 Like   #3
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,564
Make sure the lens is in the 'A' position on the aperture ring.

And no, you are not trying to do something the lens cannot do. It should function and autofocus on your camera with no issues if it is set up correctly.
08-06-2019, 02:53 PM - 1 Like   #4
Loyal Site Supporter
Loyal Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: North Syracuse, NY
Photos: Gallery
Posts: 15,570
Make sure you push the little button on the aperture ring when setting it to A.

If it still doesn't work when set to the A position you might have to clean the contacts on the lens.

08-06-2019, 03:13 PM   #5
New Member




Join Date: Jul 2019
Posts: 4
Original Poster
Thank you!

My camera is at work so as soon as I get in tomorrow Iíll be checking out that A! I hadnít noticed it today.
08-06-2019, 03:22 PM - 1 Like   #6
dbs
Pentaxian




Join Date: Jun 2010
Location: Clare Valley S A
Photos: Albums
Posts: 5,770
Hi Drtimvp

Welcome

You have to set in menu Aperature Permitted then all should be fine
I do not have a KP but it will be in the manual as to where
And the "A' setting on lens aswell

Dave
08-07-2019, 03:49 AM   #7
New Member




Join Date: Jul 2019
Posts: 4
Original Poster
Thanks all!

I now have a functioning lens - canít believe I didnít spot the ďAĒ. Bought a brand new sigma 70-210 f4-5.6 from a charity shop for £14 and thatís now working too!

Very appreciated.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, f1.4, fa, fa 50 f1.4, k-mount, lens, pentax, pentax fa, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: FA* 80-200 f2.8, FA* 28-70 f2.8, FA* 24 f2, FA 43 f1.9, M 50 f1.7, K-7, AF-540FGZ JerryFu Sold Items 6 02-25-2019 10:47 AM
FA 50 F1.4 or A 50 F1.7? abraxas Pentax SLR Lens Discussion 19 08-24-2018 08:37 AM
For Sale - Sold: (all sold ) FA 31mm f1.8, FA 77mm f1.8, FA 20mm f2.8, FA 100mm f2.8macro, F50mm f1,7 redpigeons Sold Items 8 01-12-2016 08:43 AM
For Sale - Sold: Pentax FA* 200 macro, FA* 85, FA* 24, FA 31 LTD, FA 77 LTD, A 50/1.2, VL 125 M aegisphan Sold Items 86 09-03-2009 02:37 PM



All times are GMT -7. The time now is 10:59 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top