Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-18-2008, 09:28 PM   #1
New Member




Join Date: Feb 2008
Location: Melbourne, Australia
Posts: 17
Sigma 70-200 F2.8II APO EX DG Macro won't AF on K10D

Hoping somebody can help me out here. Just bought the Sigma new and to my frustration can't get the autofucus to function on my K10D. It worked like a charm on the K20D in the shop. I called the shop and the rep said it sounded like a menu problem and suggested that I take it to the wholesaler during the week to get fixed. He "believes" that there are no compatibility issues at play here.

10-18-2008, 11:14 PM   #2
Veteran Member
Denis's Avatar

Join Date: Jan 2007
Location: St-Albert, Alberta, Canada
Posts: 333
QuoteOriginally posted by mongoose Quote
Hoping somebody can help me out here. Just bought the Sigma new and to my frustration can't get the autofucus to function on my K10D. It worked like a charm on the K20D in the shop. I called the shop and the rep said it sounded like a menu problem and suggested that I take it to the wholesaler during the week to get fixed. He "believes" that there are no compatibility issues at play here.
Make sure you have firmware 1.3 installed
10-19-2008, 12:24 AM   #3
New Member




Join Date: Feb 2008
Location: Melbourne, Australia
Posts: 17
Original Poster
QuoteOriginally posted by Denis Quote
Make sure you have firmware 1.3 installed
Hi Denis,

Thank you Kind Sir - you are both a Gentleman and a Scholar.

V1.3 loaded and hey, presto! AF now works like a charm (although it is so quiet I had my doubts initially.)
10-19-2008, 01:01 AM   #4
Veteran Member
cupic's Avatar

Join Date: Apr 2008
Location: Australia-NSW
Photos: Gallery
Posts: 4,736
And presto another forum member leaves well satisfied



cheers

10-19-2008, 07:06 AM   #5
Veteran Member
Denis's Avatar

Join Date: Jan 2007
Location: St-Albert, Alberta, Canada
Posts: 333
QuoteOriginally posted by mongoose Quote
Hi Denis,

Thank you Kind Sir - you are both a Gentleman and a Scholar.

V1.3 loaded and hey, presto! AF now works like a charm (although it is so quiet I had my doubts initially.)
You are welcome.

After using it for a few days and then switching back to a screw drive type, I almost believe something was wrong. I have a Sigma 24-60 screw drive which I will replace with the 24-70 HSM. I noticed this new lens is not macro rate anymore which may improve its IQ.

Hope you are as happy as I am with the 70-200.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
apo ex dg, dg macro, f2.8ii apo, k-mount, k10d, pentax lens, shop, sigma, sigma 70-200 f2.8ii, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma APO DG 70-200 mm Macro HSM picatalin Pentax SLR Lens Discussion 17 08-12-2009 10:31 AM
First pics with sigma 70-200 2.8ii dg hsm Taff Post Your Photos! 29 10-07-2008 07:15 PM
Sigma 70-200 mm f/2.8 II EX APO DG MACRO HSM gkopeliadis Pentax SLR Lens Discussion 13 07-10-2008 10:12 AM
Advice please: Have K10D - Pentax 50-200 + teleconverter or Sigma 70-300 APO DG? pax1231 Pentax DSLR Discussion 24 03-31-2007 08:42 AM
leopard w/ k10d & sigma 70-300 apo dg macro Evolution Post Your Photos! 7 02-12-2007 10:54 AM



All times are GMT -7. The time now is 03:38 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top