Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-05-2007, 10:12 PM   #1
Veteran Member
Finn's Avatar

Join Date: Feb 2007
Location: Phoenix
Photos: Gallery
Posts: 1,056
SR disabled with M42 adapter

I just spent way too much money on a Pentax M42/K adapter so that I could finally have that elusive infinity focus on my old screw mount lenses when I use them with my K100D. But now SR is deactivated when an M42 lens is attached, I presume because the lenses don't touch the row of metal contacts on the mounting plate of the camera body. I guess the camera doesn't know there is a lens attached at all.

Have others experienced this? If so, is there a work-around for it so that I can get SR working again? I hate to think that if I want that feature I have to use the el cheapo adapter with the big flange, since it works with SR.

Below are a couple of photos to show what I'm talking about. The pictured body is a ZX-M, because I needed to take the pics with the K100D.


Last edited by Finn; 10-05-2007 at 05:39 AM.
03-05-2007, 10:56 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,948
SR works with screwmount lenses- you just have to remember to enter the correct focal length when you turn on the camera.

I just tested it

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-05-2007, 11:13 PM   #3
Veteran Member
Finn's Avatar

Join Date: Feb 2007
Location: Phoenix
Photos: Gallery
Posts: 1,056
Original Poster
I know the screen you're referring to -- that's how it works with the knock-off adapter with a big flange (as well as any lenses whose focal length the camera can't read), but when I use the Pentax adapter it doesn't give me that screen. It just jumps to the screen summarizing the settings. On that screen, the SR hand icon is crossed out, just like if there were no lens at all.

Any ideas?
03-05-2007, 11:17 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,948
I used the original Pentax adapter as well. If the screen doesn't pop up, go into the bottom of the first tab in the menu and enter it manually.

When I took the sample shots (1/6s), the SR icon was being displayed, and the shots were sharp, so it has to work!


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-05-2007, 11:24 PM   #5
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
Hey thanks for the close ups of your ZX-M and the adapter. Haha I'll be sure to look for the Pentax branded one or at least the knock off thats physically like the real adapter. (The one that sinks into the KMount and not the ones that cover it.)
03-05-2007, 11:45 PM   #6
Veteran Member
Finn's Avatar

Join Date: Feb 2007
Location: Phoenix
Photos: Gallery
Posts: 1,056
Original Poster
Yeah thanks, they were taken with an old Tamron 90/2.5 macro that only stops down to f/5.6 -- hence the short DOF. Gotta love the curmudgeonly personalities of well-used lenses!
03-05-2007, 11:57 PM   #7
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
Ouch! But its still a very sharp lens! I can see from the pics!
03-06-2007, 02:45 AM   #8
Veteran Member
Mike Cash's Avatar

Join Date: Jan 2007
Location: Japan
Photos: Gallery
Posts: 6,952
I got one of the flangeless adapters from a Hong Kong dealer mentioned in another thread. It fits wonderfully, but I am awaiting arrival of my first M42 lens so I can't say how well it works. It fits flawlessly into the camera body, though.

I have done searches on regular big box camera stores in Japan as well as on the Pentax site and can find no indication that the genuwine article adapters are even currently in production. I have found two currently being offered on Yahoo Japan auctions and have bids in on them.

03-06-2007, 03:25 AM   #9
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
QuoteOriginally posted by Finn Quote
Have others experienced this? If so, is there a work-around for it so that I can get SR working again?
For screw mount lenses in the K100D you additionally have to set "FI with S lens used" to "available" in the menu. If it's not set SR cannot be used. (p. 49)
For the K10 this is not needed.
03-06-2007, 06:24 AM   #10
Veteran Member
Finn's Avatar

Join Date: Feb 2007
Location: Phoenix
Photos: Gallery
Posts: 1,056
Original Poster
QuoteOriginally posted by blende8 Quote
For screw mount lenses in the K100D you additionally have to set "FI with S lens used" to "available" in the menu. If it's not set SR cannot be used. (p. 49)
For the K10 this is not needed.
blende8, that did it! You are my hero!

Now if only I could figure out why it is underexposing by two stops when continuously stopping down in Av but not when using the AE-L button in M...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
adapter, body, camera, k-mount, k100d, lens, lenses, m42, pentax lens, slr lens, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
M42 Adapter stuck on M42 lenses glee46 Troubleshooting and Beginner Help 31 11-29-2011 05:16 AM
For Sale - Sold: m42 Tele-Takumar 300mm F6.3 and GENUINE Pentax m42-to-K adapter (US/CAN) LowVoltage Sold Items 5 03-22-2011 05:55 PM
For Sale - Sold: 35mm/2.8 & 55mm/1.4 m42 lenses + m42-EOS adapter heatherslightbox Sold Items 7 02-01-2010 08:26 PM
For Sale - Sold: Industar 50-2 50mm f/3.5 Soviet M42 lens + M42 Adapter 65535 Sold Items 10 11-27-2009 04:18 PM
For Sale - Sold: M42 Tair 11-A (135mm, F2.8), Genuine Pentax M42 to K adapter PrimeObjectif Sold Items 15 11-02-2009 07:20 PM



All times are GMT -7. The time now is 07:07 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top