Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-21-2009, 02:16 AM   #16
Veteran Member
Toshi's Avatar

Join Date: Sep 2006
Location: San Francisco, CA
Posts: 431
Original Poster
QuoteOriginally posted by Canada_Rockies Quote
I have the 50-135, and the AF failures with my lens can be directly fixed by cleaning all the contacts very thoroughly. Some of the lenses seem to be just a tiny bit fussier than others about the contact cleanliness. Sometimes removing and replacing the lens is enough, at other times I have to use a micro fibre cloth and alcohol. It's worth the effort to have this superb lens in my arsenal.
Thanks for the input. After posting this thread, I did read about cleaning the contacts helping another user. I've decided to take the plunge and just finished placing my order

01-21-2009, 11:46 AM   #17
Veteran Member
Hannican's Avatar

Join Date: Oct 2007
Location: Irvine, CA
Photos: Gallery
Posts: 480
Where'd you order from? I'm considering placing one too, but want to make sure I get the best deal possible.... I need to make sure I have a good multi-year warranty on it too...
01-21-2009, 02:20 PM   #18
Veteran Member
Toshi's Avatar

Join Date: Sep 2006
Location: San Francisco, CA
Posts: 431
Original Poster
I'm not sure if it's the best deal, but I purchased mine from Adorama since I've ordered from them before and have had no problems. It's 699.95 with free shipping (but I upgraded the shipping). Warranty is standard manufacturer 1 year though.
01-21-2009, 08:20 PM   #19
Veteran Member
Hannican's Avatar

Join Date: Oct 2007
Location: Irvine, CA
Photos: Gallery
Posts: 480
Thanks Toshi!

01-22-2009, 12:34 AM   #20
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
I agree with you Jay


QuoteQuote:
There is no comparison between the two - the 16-50 has (had?) a relatively high failure rate, the 50-135 doesn't.

Every single lens line manufactured is going to have a few lemons, however, so that's probably what you're hearing about.

The Tamron 70-200 2.8, while exceptional, has it's share of QC issues too - I had to send one back because of AF problems myself.

Overall, the best guarantee, IMO, of exceptional IQ in currently-made K-mount s the DA* 50-135, DA 12-24, FA/DA 35's, DA 70ltd, DA 40ltd, FA 77ltd, FA 31ltd, and FA 43ltd.

I also have the Fa 77 and the last 2 on your list are my next 2, be it next week or next year
01-29-2009, 10:28 AM   #21
Veteran Member




Join Date: Dec 2007
Location: Houston, TX
Posts: 311
Had a scare today with my 50-135. Just got a K20D off the forums and I had the lens on. Wouldn't focus. Flipped the AF/MF switch on the barrel a couple of times, and it starts working again. I fear that eventually my lens will suffer a fate similar to others. But that won't stop me from using it. This is an interesting conversation, one that I've stumbled upon more than once. Is the Pentax SDM system just inherently flawed?

Also, what is a good way to clean the contacts?
01-29-2009, 10:44 AM   #22
Veteran Member
attack11's Avatar

Join Date: Apr 2007
Location: Ottawa, ON - Canada
Photos: Gallery
Posts: 659
QuoteOriginally posted by paolojackson Quote
Had a scare today with my 50-135. Just got a K20D off the forums and I had the lens on. Wouldn't focus. Flipped the AF/MF switch on the barrel a couple of times, and it starts working again. I fear that eventually my lens will suffer a fate similar to others. But that won't stop me from using it. This is an interesting conversation, one that I've stumbled upon more than once. Is the Pentax SDM system just inherently flawed?

Also, what is a good way to clean the contacts?
the af system works when it's got proper electrical contacts. anything else is user error or a defective product.

what you described is a bad mounting. i did it once, just pop the lens off and re-seat it.
01-29-2009, 11:51 AM   #23
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,547
QuoteOriginally posted by attack11 Quote
the af system works when it's got proper electrical contacts. anything else is user error or a defective product.

what you described is a bad mounting. i did it once, just pop the lens off and re-seat it.
And if it happens too often, the micro fibre cloth and alcohol will resolve things nicely. I suspect that the contacts in the lens switch had some minor oxidation that flipping the switch back and forth cleaned up. You did exactly the correct thing when you flipped the switch a few times.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
da*, da* 50-135mm, failures, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are SDM Failures a Thing of the Past? Parallax Pentax SLR Lens Discussion 15 11-02-2010 12:58 AM
K-x/lens failures...Help!!!! LouD Troubleshooting and Beginner Help 5 05-16-2010 08:39 PM
Two DA Autofocus Motor Failures! iflyfisher Pentax SLR Lens Discussion 22 12-08-2009 02:51 PM
SDM lens failures jthommo Pentax SLR Lens Discussion 84 11-06-2009 07:45 PM
Dead Pentax *ist DS, common failures? Asahiflex Pentax DSLR Discussion 2 04-01-2009 07:44 PM



All times are GMT -7. The time now is 11:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top