Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-05-2009, 03:04 PM   #1
New Member




Join Date: Feb 2009
Photos: Gallery | Albums
Posts: 20
How does the 'A' position on an FA lens work..

Just bought an FA series 80-320 lens from ebay.
When using it on the K10D, with the Aperture ring set to 'A' I'm finding that unless i apply light pressure, holding the ring turned against it's maximum rotation - the lens does not work on the camera.

What does the 'A' position do within the lens - is operating a mechanical linkage, or operating a microswitch?

Any idea what the repair cost is likely to be?

SS.

02-05-2009, 03:47 PM   #2
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
When the aperture ring is set to "A" it engages the electrical comunicacion between lens and body. If your lens is not doing it or doing it with having tu push the ring further, it means there is a faulty contact (microswitch type). Sometimes by just moving the aperture ring back and forth (that is... from A to closest aperture) several times may fix this faulty contact. Give it a try.

In the meantime, if it doesn't work, adjust body's custom function to allow use of aperture ring and use your lens manually untill you can find someone to fix this. Dont really know how much it will be to repair it, but for sure, it won't need parts, just a good cleaning probably.
02-05-2009, 06:04 PM   #3
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
on my FA 28-80 and FA28-105 the A pin (3rd from the lens locking pin) is a switch activated pin. Early KA lenses were (I believe) a mechanical pin that moved down to contact the recessed pin in the body.

It may be that the spring in you rlens is a little tired, or the pin is dirty. You can clean it with a gum/pencil eraser.

If the fault is in the switch, that requires disassembly of the lens mount, and the apature ring. watch out, it is loaded with tons of little springs that may fly about.
02-05-2009, 11:43 PM   #4
New Member




Join Date: Feb 2009
Photos: Gallery | Albums
Posts: 20
Original Poster
Thanks guys.. gives me something to go at..

I'll not be dismantling it.. I'm going to speak to a repair shop today, if cleaning the pins doesnt work.
SS

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
fa, k-mount, lens, pentax lens, position, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aperture position when storing a lens Vranx Pentax SLR Lens Discussion 9 10-20-2010 05:59 PM
Help: Using Flash with M Lenses (no A position) Doanh Troubleshooting and Beginner Help 4 01-05-2010 01:11 PM
Av mode with lens not on A position sajah Troubleshooting and Beginner Help 16 04-18-2009 10:03 AM
540 flash w/k10d and manual lens w/o A position on aper ring qksilver Pentax DSLR Discussion 5 10-29-2007 09:18 AM
FA 80-320mm doesn't work in f"A" position Edvinas Pentax SLR Lens Discussion 7 01-13-2007 01:46 AM



All times are GMT -7. The time now is 01:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top